1. xi2y's Avatar
    Hi all, I'm just wanting to ask a question about my bold, I want to upgrade it but it used to be on vodafone (still shows the splash screen and at the start of browser) but has been unlocked and I'm using tbobile
    I heard ( don't know if this is true correct me if I'm wrong but you have to get the os for your carrier so what would I do, also would it make my phone locked again?
    Thanks in advance, first person to answer these with relevant answers will get repped+ because I've wanted to know this for a long while
    Thanks
    Ryan~

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-11 04:59 PM
  2. saudadeii's Avatar
    So first answer: No, you do not need to et the OS from your carrier. All BB OS's are released by RIM. The very latest is in the sticky at the top of the forum.

    Next, No, it will not "lock" the phone again. Once unlocked, it's unlocked forever.

    My 9000 was from AT&T on 4.6.something or other. I'm now on T-Mobile (about 1 1/2 years) running the 1067 build with no problems. I even found a theme that uses the OS 6 icons so it looks like my 9800.
    sedalia066 likes this.
    07-01-11 05:04 PM
  3. xi2y's Avatar
    Oh okay , thanks a lot for that! Helped me out, when I go on my computer in the morning ill rep you

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-11 05:09 PM
LINK TO POST COPIED TO CLIPBOARD