1. BlackHawkA4's Avatar
    So my phone was fine all day. Worked completely fine all day. Charged the batter while I was in the car before I went out after work.

    When I was out after work I took my phone out of my holster and it was off. Odd, thought it rebooted itself. Took the batter out of the back and put it back in. Phone turned back on. Put it back in the holster.

    Sometime after that took it out of the holster again and it was off. Took the battery out turned back on. Repeated the process several times. Batter meter was fine and I had plenty of charge. (Like I said I had batter when I left work and charged it back to full after work)

    After doing that several times: removing the battery and replacing it did not work. Still can not get my phone on. What is this issue? My friend suggested that I needed a new battery and it has died. Is this true/possibility?

    When i plug the phone into charge like I normally would when the phone is off the yellow light indicator does not turn on to show me the phone is charing. HELP! What's going on here?!

    I'm pathetically charging my old iPhone as I speak just so I can have a phone that works tomorrow if I can not get this one on and working.
    07-25-09 04:19 AM
  2. pinoi's Avatar
    Reinstall os...

    Or

    Search "how to recover dead blackberry"

    Posted from my CrackBerry at wapforums.crackberry.com
    07-25-09 06:01 AM
  3. piwakit's Avatar
    Just a suggestion but it sounds like you take the battery out a lot the gold connectors don't particularly like that and become damaged quite easily since it seems to happen no matter what battery you use the issue is most likely the connectors in the phone not the battery. First to ensure it is not a software issue sync your device not backup because you are going to need to reset the device and if you have corrupt software if you backup and restore you are just putting the bad stuff back in. If after the reset it is still doing this then you are probably looking at a replacement. Ill research a bit more but I am a tech for a cell carrier and this is what I would do if I were to get a call for this issue.
    07-25-09 06:37 AM
  4. BlackHawkA4's Avatar
    So I get to work and go to att around here to see if they had another battery I could try. Didn't have one in stock. Go back to work and all of a sudden my phone turns on while its just sitting on the desk.

    Its been on for about an hour now. Don't know if that helps diagnose the problem.

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    07-25-09 02:08 PM
  5. xamdam's Avatar
    Is th back cover loose?

    Is the battery seem loose when cover is off?

    Of either is loose then any little jiggle will jiggle the battery around and lose contact for power.
    07-25-09 05:10 PM
  6. BlackHawkA4's Avatar
    Nope, its not loose.

    I'm thinking, maybe, the condensation built up in the phone from thee ac being on in my room. Then, when I had the phone with me it was really hot in the car and may have dried it out.

    However, I did notice when the phone did come back on the time was way off from the actual time. Maybe it was the os?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-25-09 06:07 PM
  7. piwakit's Avatar
    If the condensation is the issue the device is hosed and will not work properly anymore hope you got insurance I'd call att for replacement if they offer that or contact rim for the 1 year warrenty
    07-26-09 12:49 AM
  8. BlackHawkA4's Avatar
    It's been working fine all day. Guess we'll see what happens.
    07-26-09 12:54 AM
LINK TO POST COPIED TO CLIPBOARD