1. cdpblackberry's Avatar
    I have just changed from an 8900 to a 9700 and I am very happy with it!!!

    One little thing I can't figure out is that when I am dialing a number it says at the top 'my number:unknown number'

    How do I change this to display what my number is??

    Many thanks,

    Chris

    Posted from my CrackBerry at wapforums.crackberry.com
    06-04-10 07:34 AM
  2. fatboy97's Avatar
    Check in Options > Phone Options > General Options > Show "My Number"... does this say Yes???
    06-04-10 07:38 AM
  3. cdpblackberry's Avatar
    Yes it does....

    Its like the handset doesn't know what my number is??

    Posted from my CrackBerry at wapforums.crackberry.com
    06-04-10 07:52 AM
  4. fatboy97's Avatar
    Next, change themes... if that does not work, then do a Battery Pull (leave your device on, pull the battery out for 20 seconds, put it back in and wait for it to boot up) OR a soft reset (Alt + Right Shift + Del... this will reboot your device, but you don't have to pull the battery).
    06-04-10 08:42 AM
  5. Pi Guy 3.14's Avatar
    What about options > advanced options > sim card? What phone number does it say there?
    06-04-10 08:43 AM
  6. cdpblackberry's Avatar
    Thanks all....its sorted now...

    In advanced options it said unknown number so I changed it

    Posted from my CrackBerry at wapforums.crackberry.com
    06-04-10 09:40 AM
  7. Pi Guy 3.14's Avatar
    I knew that would work

    Lol @ the battery pull... When in doubt, just throw a 'do a battery pull' in there
    06-04-10 09:44 AM
LINK TO POST COPIED TO CLIPBOARD