1. 420Boldly's Avatar
    Hey.

    After owning a bunch of different smartphones, I'm a Bold user now. Unfortunetly I am having some difficulty setting up my text messaging.

    The Bold is unlocked. I am able to receive SMS messages but do not have a reply option(either with trackball or menu). When I go to my contacts I have no option for SMS or MMS.

    I am the second owner of this device. Is it possible the the pervious owner erased something to do with replying to messages?

    Also I have contacted my provider to acquire the proper SMS Centre number. This did not change anything.

    Neither Rogers or Fido were very helpfull in providing a solution. Hopefully someone here will be able to help.

    Thanks
    05-25-09 02:58 PM
  2. dsdawson's Avatar
    Have you tried:
    Options->Advanced Options->Host Routing Table->Register Now

    Doug
    05-25-09 03:57 PM
  3. MobileMadness002's Avatar
    Check to make sure your SMS # is set correctly. For Rogers the SMS number should be +17057969300, Data Coding=7Bit, at least thats what I have in my BB.

    Oh, you dont even have the options. Not sure on the MMS, but the above should work for the SMS.
    05-25-09 04:16 PM
  4. 420Boldly's Avatar
    I have tried the host routing table thing. Says registration message sent...and thats all.

    I did also set the SMS # for Fido. This didn't do anything either.
    05-25-09 04:35 PM
  5. Cocotaso's Avatar
    You can try to enter the number +17057969300 for the Service Center

    Thats what i have for my Rogers phone. but i'd assume it would work since Rogers+Fido is pretty much the same?

    Give it a try!
    05-25-09 05:36 PM
  6. 420Boldly's Avatar
    Hey. Thanks. I tried using the Rogers Service Centre and a different Fido number as well. Neither have changed anything in the messaging menu.
    05-25-09 06:43 PM
  7. deeman54's Avatar
    Have you tried:
    Options->Advanced Options->Host Routing Table->Register Now

    Doug
    this is the correct operation
    05-25-09 07:18 PM
  8. 420Boldly's Avatar
    Thanks for all the suggestions so far. I wiped the device and tried all suggestions again...but still no SMS option in menu or no reply to received messages.

    When I tried Options->Advanced Options->Host Routing Table->Register Now - it said Registration message sent...and that was it.

    Hope I didnt buy a dud!
    05-25-09 08:13 PM
  9. 420Boldly's Avatar
    Hey All. Need to bump this back up there. I am in serious need of some help. I rely heavily on SMS messaging...and since I bought the bold I have been unable to send any. Here are the things I have done so far. Everything else works on the device. I can receive SMS but cannot reply. Also when I go to the SMS folder I do not have an option to compose SMS.



    Wiped device and installed .266

    Upgraded to Desktop Messenger 4.7 after customer support said I need that version

    I have the proper SMS Service Centre Number.

    I have done the Host Routing Table and received verification via email.

    Please HELP!!

    Thanks
    05-28-09 09:20 AM
  10. dsdawson's Avatar
    You did mention that the BB is used. You might be the victim of a previously installed IT policy.
    Have a look here:
    http://forums.crackberry.com/f3/remo...lackberry-569/

    Doug
    05-28-09 09:31 AM
  11. 420Boldly's Avatar
    Doug...You are a God amoung men! Used the the IT removal and now I have SMS. Much Thanks.
    05-28-09 10:22 AM
  12. sandos's Avatar
    Doug...You are a God amoung men! Used the the IT removal and now I have SMS. Much Thanks.
    Damn corporate SMS nazis...

    Posted from my CrackBerry at wapforums.crackberry.com
    05-28-09 10:25 AM
  13. Reed McLay's Avatar
    Doug...You are a God amoung men! Used the the IT removal and now I have SMS. Much Thanks.

    That is great news, I can't think of another reason that SMS would be disabled on the device.

    05-28-09 10:36 AM
LINK TO POST COPIED TO CLIPBOARD