1. Couver81's Avatar
    Hopefully someone else has experienced this and has a fix.

    I got my 9790 about two weeks ago but it was an extremely long process to get it all setup (ugh Telus). Anyway long story short it is all setup now and everything seemed to be working fine until I tried to make a call. There is absolutely no sound when I make an outgoing call. No ringing and when the person I am calling picks up I can't hear that either. The strange thing is if I switch from handset mode to speaker I hear it all fine and they hear me. I haven't tried receiving calls yet so I'm not sure if that is working or not. I'm going to test that shortly.

    Anyone have any idea what the issue could be? I've played around with the sound and call options with no luck. The speaker must be alright though if it can produce sound on speaker and I've had no problem listening to music either.

    Any help would be much appreciated, thanks!
    04-18-12 04:56 PM
  2. Phill_UK's Avatar
    The phone earpiece on the front isn't the same as the media speaker on the back.

    Anyway, to increase the volume whilst in a call just press the volume up key on the side of the phone.

    You can also set the volume by going to Options > Call Management > In-call Settings > Volume Control.
    04-18-12 05:07 PM
  3. 4speed's Avatar
    I have the same problem on my Bold 9900. I took it back to my carrier and they are going to fix it under warranty
    Last edited by 4speed; 04-19-12 at 04:56 PM. Reason: Update
    04-18-12 05:41 PM
  4. goshko's Avatar
    if ur phone is still under warranty dont wait and return it asap. there is obviously a problem with it and you should replace it.
    04-18-12 05:58 PM
  5. Couver81's Avatar
    Well a battery pull seems to have resolved the issue for now. I'm hoping it won't return but who knows? I wish I knew the cause so I could prevent or guard against it.

    4speed that sounds terrible. Have you tried going to your carrier and asking them if they can replace the phone? It sounds like an obvious defect.

    Thanks for the help everyone
    04-18-12 08:27 PM
  6. alan510's Avatar
    On the official BB site, there is some discussion of this issue. BB calls it a 'known' issue I believe.

    I too had the same problem. The battery pull seems to have worked for me as I haven't had any problems since the battery pull. Let's all hope that it is solved for the long term.
    04-18-12 08:42 PM
  7. Couver81's Avatar
    Well looks like the battery pull was only a short term solution for me. Phone is doing the same thing again today. And I literally did nothing with it this morning but turn it on and try to make a call. So it lasted about two days. I'll do another pull for now but this is very frustrating. I want to take it into Telus and got a new one but I'm gun shy now knowing that this is an issue.

    Does anyone think it could be the OS? I'm still on 7. That I know of Telus hasn't rolled out 7.1 for this device yet. DM manager still tells me there are no updates.
    04-20-12 12:46 PM
  8. tanujdewan's Avatar
    Try clean reload of the device software using desktop software. have been suggested the same by local engineers here in india.
    Lets see if it works.
    04-27-12 04:47 AM
  9. Couver81's Avatar
    I ended up taking it back and getting a new one since I was within my 30 days. So far the new one is fine. The rep at Telus did say he thought it was a software issue and that 7.1 would fix it. Of course they haven't released it yet for the 9790. Fingers crossed this new phone doesn't have this issue.
    04-29-12 04:20 PM
  10. torpesco's Avatar
    Reviving an old thread... Did you ever have the issue again on your new device? I just got a 9790 three weeks ago and on Friday it did the same thing. Battery pull solved it, then it happened again Saturday and again this morning. I just wiped it, reloaded the OS and restored my data... but if you haven't had the issue on your new device, maybe it's actually some bizarre hardware-related manufacturing defect?
    01-14-13 06:31 PM
  11. torpesco's Avatar
    Just found another forum thread that blames a couple of free flashlight apps. Wish I'd seen and tried that first.
    01-14-13 09:15 PM
  12. Strikkie's Avatar
    Try the search button for "microphone stopped working
    01-15-13 07:26 AM
  13. Innocent M's Avatar
    Hi guys. I seem to have the same problem with my blackberry Q10. I recently bought it from someone and did a software upgrade to the OS. Music plays very well and yet I cannot hear or make calls. Anyone help please.
    11-25-13 01:37 AM