1. createwww's Avatar
    Please help,

    I have a 9780 and my wife has a new Curve 9360 - up until a week ago i had no issues at all but now when we leave the house and are only connected to the Mobile Network we can not get data services unless we shut off the mobile network and then re-connect.

    I am getting the run around from Bell stating that you ALWAYS have to switch off your wifi when you leave a wifi network.......now i and the rest of the world know that that is not the case, i have used a BB on my wifi for over 3 years with no issues - i have not changed a thing on my home wifi

    The strange part is that when i get to work and re-connect to wifi (45 mins away) data starts to come through again....after being at work for the day and i leave the office wifi data services continue to work.

    This to me would sound more like a carrier issue not a BB issue.....anyone help?
    11-08-11 07:58 PM
  2. Rootbrian's Avatar
    Resend the servicebooks, re-register under the host routing table, try a battery pull. Toggle data services off, then back on after waiting 5 seconds. I had to do that a few times to get data to come back.

    Do you by any chance have any recent apps installed and when using them, does it cut off mobile data? You might want to remove, reboot if prompted, and reinstall them. Google maps was a factor with me and after reinstalling it, data worked normal, even after walking away from a wifi area.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-09-11 10:50 PM
  3. sdeangelis's Avatar
    It's not the phone provider, I get the same on a different phone provider
    04-26-13 12:04 PM
LINK TO POST COPIED TO CLIPBOARD