1. bryan_c's Avatar
    Just got it in the mail because my other was messing up, did an exchange and now when i turn it on. All i get is a white screen. Happened to anyone else?
    07-03-09 01:34 PM
  2. jackie treehorn's Avatar
    is it the spinning hour glass or does it have any words on it? Sounds like there might not be an os on it for some strange reason
    07-03-09 01:35 PM
  3. bryan_c's Avatar
    Nope, just a blank white screen.
    07-03-09 01:37 PM
  4. jackie treehorn's Avatar
    see the recover dead berry link in my sig
    07-03-09 01:38 PM
  5. BrandonB510's Avatar
    Call Customer Support :O
    07-03-09 01:39 PM
  6. bryan_c's Avatar
    On the phone with them now, like arent they suppose to check these before they get sent out? lol. Really ATT?
    07-03-09 01:41 PM
  7. jackie treehorn's Avatar
    Yea but its a pretty easy fix instead of having to send it back and wait for a new one
    07-03-09 01:42 PM
  8. bryan_c's Avatar
    Im just going to order a new one and send the old one back, but now i turn on my phone that does mess up sometimes. I boot it up i get like 5 errors and half of my icons are missing. Blackberry really knows how to get under your skin sometimes.
    07-03-09 02:03 PM
  9. BrandonB510's Avatar
    Arent all replacements just refurbished?
    07-03-09 02:54 PM
  10. kyleCRAZE's Avatar
    i used to have those error messages, i just upgraded the OS and it was perfectly fine, never had those messages again.
    07-03-09 03:15 PM
  11. krep21's Avatar
    Had the same thing happen with my curve, they overnighted another one out to me
    07-03-09 03:24 PM
  12. ausch's Avatar
    Arent all replacements just refurbished?
    Yes, but I think if you get like 3 replacements they send you a brand new one.
    07-03-09 03:25 PM
  13. bryan_c's Avatar
    Will see what happens, I hate switching pins and everything. So annoying. Should have a replacement here monday and take it from there
    07-03-09 05:03 PM
LINK TO POST COPIED TO CLIPBOARD