1. gp1200r2000's Avatar
    i just had to call someone and i blocked my number by going into the options and hitting block my number,or what ever it says,I hit always now When I go back it just says general options oe default
    I need help to get this back correct because I dont need my number blocked anymore..Please help thanks Craig

    This is on my bold
    08-13-09 05:09 PM
  2. nikolous's Avatar
    go into general options and next to "restrict my identity" select never
    08-13-09 06:37 PM
  3. jevon96's Avatar
    need help with app that will allow only contacts to come thru.
    08-13-09 06:58 PM
  4. my240sx88's Avatar
    i,Call Manager Light.

    that should be what your looking for. its not free tho
    08-13-09 08:51 PM
LINK TO POST COPIED TO CLIPBOARD