1. kimbokrn's Avatar
    Hey guys.

    I'm in a big doodoo right now. So, it kind of happened shortly after I attempted restarting my phone (left alt+right caps+del). The symptoms that my BB is facing are these:

    1. The trackpad is stuck on the magnifying search button & does not move at all on the homescreen. But the clicking works on the homescreen. Also, I can confirm that the scrolling & clicking functions both work on notepad since that's my convenience key assignment. However, the scrolling function does not work everywhere such as multitask, some menus.

    2. My right caps button seems to have been reassigned as the letter "p."

    3. My delete button seems to spam the letter "p."

    4. My enter button seems to do "enter" then capital "P."

    5. My "p" button is not assigned to anything.

    I have uninstalled & reinstalled the OS. I have tried wiping all the data. I don't believe this is a hardware issue, but more like something I caused from pressing wrong buttons.

    Can anyone help me please? :[[

    Thank youu
    07-17-11 03:15 AM
  2. kimbokrn's Avatar
    hmm.

    *when i press a letter like o and scroll up & down, different accented o's show up, leading me to believe that the scrolling function's reassigned to that? wtf -_-

    is there any way to reset the whole keyboard assignments via. computer?
    07-17-11 03:26 AM
  3. Motorcycle Mama's Avatar
    Sounds like moisture damage.

    Has the device been exposed to ANY moisture? Even a little tiny bit?

    Wet hands, wet hair, steamy bathroom sweaty pocket, high humidity environment?
    07-17-11 06:35 AM
  4. greggebhardt's Avatar
    I have to agree with Motorcycle Mama and it sounds like classic symptoms of water damage. It does not take much and you might not have been there when it happened. Who else had access to your phone?
    07-17-11 07:16 AM
  5. kimbokrn's Avatar
    moisture damage..? really?
    the device must be really sensitive to it or something cause i've never handled my device in any type of wet environment of with wet hands..

    &only i use my phone.

    but swear to god it started acting this way after i tried restarting the device..
    07-17-11 10:57 AM
  6. anon(3733516)'s Avatar
    try reloading the OS and see if that fixes anything..

    but if not, sounds like it's hardware damage.
    07-17-11 06:45 PM
  7. kimbokrn's Avatar
    I let the battery drain, then recharged it.
    Seems to work normally now.

    Thanks erryone.
    07-18-11 08:57 PM
LINK TO POST COPIED TO CLIPBOARD