1. dc2x4drvr's Avatar
    I just got a refurb Bold because my original's display was flickering and fading out, I had .282 on it along with an 8gb media card which worked fine.
    Here's my problem, my phone recognizes the media card, but my computer doesn't see it. I've done the obligatory battery pulls, verified that Media Card Support is on, Prompt when connected...I've even downgraded to .266, but nothing has worked, plug the usb cable in, click on My Computer-the card does not show up
    I had a conversation with an ATT Blackberry guy, and he didn't have any ideas either.
    Has anyone got any ideas???
    06-26-09 04:38 PM
  2. username0022's Avatar
    Try this...

    Go to System>Options>Memory

    The first four lines should read:

    Media Card Support : "ON"
    Encryption Mode: "None" (you can change if you want, I guess)
    Mass Storage Mode Support: "ON"
    Auto Enable Mass Storage Mode When Connected: "YES"

    Plug it in to your computer, you should then be prompted for a password (if you have one, if not don't worry), then look for the drives under "My Computer".

    See if that works.

    If not, I'd try another card reader.
    Last edited by S7ar Scr3am; 06-26-09 at 04:52 PM.
    06-26-09 04:41 PM
  3. dc2x4drvr's Avatar
    Did all of the above, and btw, I've also tried my laptop, same result...and I've tried another media card...
    06-26-09 05:12 PM
  4. username0022's Avatar
    How do you say "weird" in 10 or more characters? Wait... Nevermind.

    Sorry, that stinks. Hope you find an answer.
    06-26-09 05:41 PM
  5. anon(153966)'s Avatar
    Do you have a laptop?

    If yes, take the memory card out of your BlackBerry, insert it into the adapter that came with it, insert into your laptop.

    Now, copy the data from it, format it, then place it back into your Blackberry.

    Once back in your BlackBerry, connect to your laptop\pc via the cable, and then you should be able to copy the data back from the pc to the memory card via the cable...
    06-26-09 05:52 PM
  6. dc2x4drvr's Avatar
    Yay, I found the fix...search hahanew.exe and run the file. Apparently some of the refurbed Bold's are being shipped with Mass Storage Mode off, even when Mass Storage is selected to on.
    Anyhow, when I ran the file the E: drive shows up, just like it used to.
    06-28-09 07:56 PM
  7. anon(153966)'s Avatar
    Thanks for sharing this.

    But, to be clear for other users, I'm guessing you're saying to run said file on the pc? And one gets this file by installing the software (OS) for said device?
    06-28-09 08:33 PM
  8. dc2x4drvr's Avatar
    Save the file to your desktop, run the file with your BB connected, hit enter when on DOS, and wait for your berry to reboot.
    06-28-09 10:06 PM
  9. dc2x4drvr's Avatar
    Save the file to your desktop, run the file with your BB connected, hit enter when on DOS, and wait for your berry to reboot. This is a patch to the OS.
    06-28-09 10:09 PM
  10. pmdejesus's Avatar
    I bought a media card and removed it from the phone I went to put back and now my phone is saying that it needs to be format it and when I try to format the media card it says that the format failed. When I try to do it from the computer it says that it is a read-only file. How do I change the media card from a read-only file.
    08-03-09 04:53 PM
  11. wrrecked's Avatar
    Wait, so what did you do? I'm having the same problem. I can't access my media card through USB connection.
    08-03-09 04:57 PM