View Poll Results: I had a mass storage device feature problem on:

4. You may not vote on this poll
  • A new phone

    1 25.00%
  • A refurbished or used phone

    4 100.00%
Multiple Choice Poll.
  1. centerfield's Avatar
    If the mass storage device feature on your bold does not work and you have already tried everything directed by BlackBerry Tech support, then check this thread (oops, I can't post links even to crackberry threads - you can get there by searching for this phrase: "BB storage Activation new" in a post by Sandlotje which includes step by step instructions for downloading and running the program.)

    It may be that your mass storage device feature was disabled (not by the on-off setting that you can access in setup, but rather internally.) The program referenced in that link will reset the mass storage device feature. It worked perfectly on both "defective" bolds sent to me by ATT.

    More importantly, I want to vent about BB's approach to this issue. I spent 5 hours with BB tech reps trying to resolve the issue. After the first 3 hours they said the phone was defective and they directed ATT to replace it. When the second phone had the exact same problem after 2 more hours they said "we'll have to consult with senior tech specialties and get back to you" which they never did.

    Then I found the hahanew.exe fix.

    So I called BB tech back about my open ticket and told them that I had found the source of the problem (the mass storage device feature was internally disabled) and the hahanew.exe fix for the problem.

    At first, the rep acted like he knew nothing about the nature of the problem or the fix. When I confronted him about the hundreds of posts on the BB forum and other forums like crackberry and pinstack, he then admitted that in fact the mass storage device could be disabled internally by the application of third party software.

    When I asked why BB didn’t simply post that information and the fix at their website he said because BB tech support is not allowed to resolve issues caused by third party software, and that the fix appears to be based on upon a program designed only for internal use by BB tech support.

    Fair enough, but, when a consumer calls about the problem and all other standard methods of resolving the issue have failed, why not just say:

    "It may be that your mass storage device feature was turned off internal by the application of some third party software. We do not provide support to resolve problems caused by third party software. You may be able to find a third party fix for this problem by searching the web. However, you use any third party fixing program at your own risk."

    Instead of wasting hours and hours of their time and my time acting as if the problem is some unknown defect and hoping that the consumer returns the phone (if still under warranty) and gets a new phone without the problem.

    BTW, I had this problem with the two refurbished phones I got from ATT. That is not an excuse for ATT because they sell the phones with the designation of "Certified Refurbished Equipment" which is another way of saying "the damn phone is supposed to be working."

    BB tech suggested that this problem never exists with new phones, just "refurbished" ones. I'm not so quick to believe that because the tech's theory was that the people who returned the new phones to ATT must have "messed with the phone trying to unlock it before returning it."

    That seems a bit far-fetched. And in any event, ATT should be testing the phones to be sure they work before putting the "Certified" sticker on the box.

    Has any one had the problem with a new BB?
    Last edited by centerfield; 03-24-09 at 09:41 AM.
    03-24-09 09:36 AM
  2. alexwall77's Avatar
    Yes, I had the exact same problem with two refurbished Bolds just like you.
    Last edited by alexwall77; 04-13-09 at 11:48 AM.
    04-13-09 11:27 AM
  3. BostonNewB's Avatar
    Does this fix work for 8300s? I'm having the same issue with my refurbished Curve...
    04-13-09 02:48 PM
  4. mwtallman's Avatar
    Had the exact same problem with the Blackberry Storm. My original worked fine. I took it back to Verizon Wireless to replace it because the interface kept locking up. They provided me a refurbished Storm. I take it home and cannot get my computer to see it! Therefore I can't access Mass Storage, My Computer shows no drives, you know the story.

    Blackberry's Device Manager software worked fine. Thats what was puzzling me. Thought it was a defective phone! Returned it again, to get a second refurbished phone and it did the same thing! I was livid! Verizon basically told me there was nothing they could do but to call tech support.

    Then I found the hahanew.exe patch and everything works great now!

    Unfreakin' real! I to am upset at how BlackBerry has handled this. You would think they would let their carriers know about this issue. Frankly, I think (at least in Verizons case) when they get back Storms and refurbish them, they obviously wipe the phone and install the latest OS, etc. I think during that "imaging" process, the mass storage feature gets disabled internally, which is why I didn't experience the issue with my first "brand new" phone!

    Thanks to whoever wrote hahanew.exe! They are a life saver!'
    08-03-09 09:41 PM
  5. StormChaser77's Avatar
    ugh.. i might be a victim here.. still working on it.. this sucks..
    04-11-10 04:27 PM
  6. StormChaser77's Avatar
    the hahanew.exe program doesn't work on my phone. says it is too old for my device. Great.. guess I will have to call AT&T.. this is a pain in my arse..
    04-11-10 04:50 PM
  7. StormChaser77's Avatar
    Ok, had to downgrade to Once that was done, ran the .bat file for the hahanew.exe. It worked. So now, in the process of upgrading to .592. I hope it still works.

    When I tried to use the hahanew.exe program before, it said I couldn't cause the loader was to new for the .554 OS. So, if this is a problem you are having, you have to downgrade first. Just an FYI.

    I will post back once it has successfully been upgraded to .592.
    04-11-10 07:23 PM
  8. StormChaser77's Avatar
    It worked. Everything is fine now. As I stated above, that is the process in case you had the same error I did.

    04-11-10 08:43 PM
  9. delta1's Avatar

    I fixed mine by using the engineering screens code generator available on the web.

    This locked thread shows how. Post 12 is the one.

    No downloads, simply access the engineering screen and turn it back on!

    If the problem reappears, I'll report back.

    Thanks to the posters on the locked thread for the solution.


    Last edited by delta1; 04-12-10 at 06:00 PM.
    04-12-10 05:37 PM