1. tag824's Avatar
    OK, so I messed up . I got a new black bezel from cnn.cn and installed it but now my left side button doesn't work. I took the phone apart but everything looks OK. And before anyone asks, yes the button has something assigned to it so it's not the OS. The button presses and gives feedback just like before but just doesn't work.

    If I did mess up the button would replacing the midplate fix it? Any help is appreciated.

    TIA
    03-18-09 01:43 AM
  2. Tronyx's Avatar
    Have you tried the all fixing batt pull?

    Chris
    03-18-09 01:53 AM
  3. tag824's Avatar
    Yes, I had to pull the battery when I took it apart again to try to figure out what was wrong.
    03-18-09 02:00 AM
  4. Tronyx's Avatar
    Are you sure that the button is in properly? Did it not work right from reassembling the Bold?

    Chris
    03-18-09 02:03 AM
  5. bmho's Avatar
    Try taking it apart once more and make sure it is in the right place. Sometimes it's just skewed off a bit and it won't work right.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-18-09 02:04 AM
  6. tag824's Avatar
    Unless the Bold needs microscopic precision I do have everything lined up properly. Button presses smoothly just like before. The button simply sits in the cut out on the bezel and the midplate sits inside around the bezel holding the buttons in place. I already took it apart and resat everything. All of the other buttons work except for the left one.

    I was hoping that someone knew if the midplate replacement would fix the issue or if there could possibly be something wrong with the system board? Sigh, I hope to God not.
    03-18-09 02:14 AM
  7. SiDeeFung's Avatar
    To the OP, Steve from cnn.cn here

    I've encountered the exact same problem before, the issue being that the midplate (the part with the loudspeaker and stuff) was not touching the mainboard fully. This was due to a bent screw, and as such, it wasn't screwing down all the way (the centre screw, on the right if looking at the battery). Please check to ensure the pins are making full contact with the midplate.

    Also check the pins on the midplate, they may have been bent, or broken.

    Steve Chan
    Cellular Accessories - Samsung, LG, Motorola, Apple, Mobiado, Alcatel, SonyEricsson, Tools, Nokia, Acce
    03-18-09 02:27 AM
  8. tag824's Avatar
    OK, this is funny Steve because we emailed each other back and forth regarding the status of my order over the weekend. Ha, small world. Thanks for being so prompt on your replies and thank you for the suggestion. It's getting late here but I will look into the midplate contact points and make sure the midplate is secured tightly first thing tomorrow.

    Thanks!
    03-18-09 02:35 AM
  9. tag824's Avatar
    OK, so I checked and double checked. Everything is fine, no bent screws or pins. The midplate is contacting all the pins. It's gotta the button on the midplate is broken or worse something with the system board. I'm just going to get a new midplate and see if that fixes it. SOB!
    03-18-09 01:35 PM
  10. rjkolo's Avatar
    I am sure there is a video on line somewhere to see if you missed something while taking it apart or putting it back together.
    03-18-09 01:39 PM
  11. tag824's Avatar
    I got it on all correctly. In fact I just helped a coworker put on his black bezel and reassemble the phone and everything works on his.
    03-18-09 03:27 PM
  12. idfx's Avatar
    I've seen this happen to a regular bold.
    No modifications made (so no taking apart).
    The left button works occasionally, but for the most part its ineffective.
    03-18-09 03:35 PM
  13. judicator's Avatar
    I think this happened to me to, except for the fact that the button ripped off the midplate, so there's an option?
    03-18-09 08:03 PM
  14. tag824's Avatar
    UPDATE:

    So I got my new midplate today from cnn.cn. Popped it in and BAM, my left side button works now! I am so relieved it wasn't something with the system board. Just wanted to let everyone know what my resolution was in case someone else runs into the same problem.

    Thanks to all the replied!
    03-19-09 01:45 PM
  15. jstray's Avatar
    so funniest thing...... my volume button was not working and i read this and so i tightened the screw by that button and bam! lol i was all ready to order a midplate from cnn
    07-01-09 04:19 PM
LINK TO POST COPIED TO CLIPBOARD