1. alorriman's Avatar
    I have my Keep messages setting set to forever but my inbox will only show emails as old as from 1 week ago.... can anybody tell me why?
    09-03-08 08:27 PM
  2. pltaylor's Avatar
    double check the settings make sure you hit save after setting to forever.
    09-03-08 08:30 PM
  3. alorriman's Avatar
    It certainly appears I've done it correctly and saved the settings. All other folders appear to have the same problem.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-03-08 08:36 PM
  4. StoneRyno's Avatar
    I don't have the bold but I can mention a bug that occured on 4.3.0.127 that comes on the 8330. Keep forever acted as keep for 30 days and keep for 30 days acted as keep forever. Perhaps a similar thing is happening, but in your case is 1 week. This is assuming there is a one week setting for keep messages.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-07-08 03:43 AM
LINK TO POST COPIED TO CLIPBOARD