1. Beesh1's Avatar
    Hi there,
    So I just got back from being on holiday and on my 9900 I keep getting sos or no service. This has been happening for 3 days and I'm getting quite annoyed as you can imagine due to BBM not working, or being very slow, getting late whatsapp messages and my SMS messages not even working.
    I'm with O2, and I went in to store today and talked to a manager about it and all he did was the "host routing table" option thing which I usually do anyway but that has still not helped the situation. So I'm asking if any of you guys know how I could get this thing working again?
    Any help is appreciated!
    06-19-13 03:46 PM
  2. dangerousfen's Avatar
    I suppose you've already pulled the battery?

    Sent from my BlackBerry 9900 using Tapatalk
    06-19-13 04:16 PM
  3. Beesh1's Avatar
    Lol.... Battery pulled and restarted a lot of times. Still not worked.
    06-19-13 04:21 PM
  4. DStLouis's Avatar
    Hi there,
    So I just got back from being on holiday and on my 9900 I keep getting sos or no service. This has been happening for 3 days and I'm getting quite annoyed as you can imagine due to BBM not working, or being very slow, getting late whatsapp messages and my SMS messages not even working.
    I'm with O2, and I went in to store today and talked to a manager about it and all he did was the "host routing table" option thing which I usually do anyway but that has still not helped the situation. So I'm asking if any of you guys know how I could get this thing working again?
    Any help is appreciated!
    Have you called your carrier ?
    I had that problem when flying thru Europe and South-Africa, only SOS calls were apparently possible.
    When I called my carrier they have made a change on my account unblocking call or service in area other then your typical area (Like Canada and USA for me). They were doing this in order to limit unwanted heavy bill by you or by some counterfeithing.
    06-19-13 04:24 PM
  5. Beesh1's Avatar
    I went to my carrier today (O2) and the manager did something with the host routing table which should have worked but hasn't really done anything. Nah, I'm not flying through UK, I was coming back from being on holiday I actually live here so it should be like normal but isn't.
    06-19-13 04:33 PM
  6. goodayeh's Avatar
    Was having same problem on my old Storm 2.
    The Sim card wasn't making proper contact.
    I inserted a slip of paper to keep it in place.
    06-19-13 11:15 PM
  7. Beesh1's Avatar
    Did that work for you? Well, the thing is, I do have service at times and sometimes it can be a long time, but then it can also suck a lot of the time and end up not working for ages.
    06-20-13 04:15 AM
  8. Beesh1's Avatar
    So I reached out to O2 on twitter and they said it could be a fault with the phone because if it was the sim card going wrong, it wouldn't be working. So hopefully this fixes it... Probably a sign I need a BB10 phone.
    06-20-13 01:10 PM
  9. fryk's Avatar
    I had an issue like yours and took it to the ATTdealer and they replaced the sim card for free. Fixed.
    06-21-13 12:09 AM
  10. Beesh1's Avatar
    Alright thanks, it might be a sim card error so i'll try that out.
    06-21-13 03:57 AM

Similar Threads

  1. Help! I keep getting sos
    By Xamanus in forum BlackBerry Bold Series
    Replies: 8
    Last Post: 11-29-11, 07:42 PM
  2. Got to ask this question again as it keeps getting lost or moved
    By BlackBerryMan83 in forum BlackBerry Curve Series
    Replies: 2
    Last Post: 11-05-10, 06:00 PM
  3. sos and no service
    By USDCoyote in forum BlackBerry Curve Series
    Replies: 3
    Last Post: 11-25-09, 09:51 PM
  4. Replies: 12
    Last Post: 02-15-09, 01:41 PM
  5. SOS calls & No service on device
    By anon(153966) in forum General BlackBerry News, Discussion & Rumors
    Replies: 6
    Last Post: 05-26-07, 11:31 AM
LINK TO POST COPIED TO CLIPBOARD