1. BlankBerry's Avatar
    And I was very very carefull about taking it apart (heck I even washed my hands before)..LOL Then I get to the tack ball "clip" thing I'm trying to grab the bottom of the clip with a small dental tool poink one side then poink the other side...Seems to have came out fine..I cleaned ball with rubbing alcohol & can'o air.let dry a few minutes & as I was putting the clip back on to hold ball in place I took my magnifying glass out to get it in the exact position & noticed both of the tiny pieces of plastic where the clip clips onto have broke right off..!?!?

    Now Im like Son of A D'oh..!!

    I managed to get it clipped down completely on one side (right under screen) but only partially on the bottom side..It works great now but still Im worried about that clip anyone think it could come loose & do any damage or short junk out..?

    Thanks All..
    06-23-09 12:44 AM
  2. dieseldude's Avatar
    I think it would come loose but I dont think it wil short anything out unles it gets wet of some thing.
    06-23-09 12:48 AM
  3. BlankBerry's Avatar
    Yeah I dont think it would move around in there @ all to touch any of the board to short anything out (cause the clip is metal) but still worry's me..lol
    06-23-09 12:50 AM
  4. dieseldude's Avatar
    I understand, you could always use tape to hold it in untill you get a new ring loljk, Have you ordered one yet by chance?
    06-23-09 12:55 AM
  5. BergerKing's Avatar
    This would be your opportunity to order spares. Amazon.com has a 2 pack for about $10. EBay is another good source.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-23-09 12:57 AM
  6. dieseldude's Avatar
    ^thats good to know a freind needs them
    06-23-09 12:58 AM
  7. BlankBerry's Avatar
    Actually I think its attached right to the main board isnt it..? Its the black square where the ball sits into then the clip holds the ball inplace clipping onto that square piece coming from the board..I dunno I paniced & just put it all together to make sure it still worked..LOL
    06-23-09 01:09 AM
  8. dieseldude's Avatar
    if all side are not down and wont stay down I think the clips are damaged I would get a new one or two.
    06-23-09 01:11 AM
  9. BlankBerry's Avatar
    The metal clip is fine its the small black pieces of plastic that clip is held down with...Theres a video of it here somewhere I'll search for it..

    here it is look closely @ the black plastic where the ball goes
    Last edited by BlankBerry; 06-23-09 at 01:24 AM.
    06-23-09 01:20 AM
  10. ahern090's Avatar
    too bad you dont have a storm.. then you wouldnt have to worry about trackballs. lol jk ebay def. has some good deals on the trackballs, plus you can change the color if you have to order a new one.
    06-23-09 01:23 AM
  11. BlankBerry's Avatar
    too bad you dont have a storm.. then you wouldnt have to worry about trackballs. lol jk ebay def. has some good deals on the trackballs, plus you can change the color if you have to order a new one.
    Yeah I know I should have waited for the storm & should have learned from my 8800 had nothing but problems with the ball in it and of course as soon as I bought the bold it started working just fine again..lol
    06-23-09 01:37 AM
LINK TO POST COPIED TO CLIPBOARD