1. JvKintheUSA's Avatar
    Okay, so I got myself a new Bold from Rogers and unlocked it. Went to the AT&T store to get a SIM card, but once inserted it says on the top of the main screen "Insert SIM Card", and instead of signal strength bars I get "SOS". The guy in the store tried it with his SIM card and same issue. He inserted my new SIM in his IPhone and it worked, so it is not the SIM card. Any suggestions?
    09-15-08 07:36 PM
  2. Branta's Avatar
    Unlock failed?
    If you still have a Rogers sim from the Locked era see if that works. If this also fails to read it might be the SIM reader contacts need a clean, or a failed SIM reader. (not sure if you can get at the contacts on a Bold, but try reseating the card several times if its a slide-in)
    09-15-08 07:47 PM
  3. JvKintheUSA's Avatar
    Unlock failed?
    If you still have a Rogers sim from the Locked era see if that works. If this also fails to read it might be the SIM reader contacts need a clean, or a failed SIM reader. (not sure if you can get at the contacts on a Bold, but try reseating the card several times if its a slide-in)
    Under the advanced options it shows that the phone is unlocked (SIM-disabled, Network-disabled, network subset-disabled, service provider-disabled, corporate-disabled), and I tried reinserting the SIM several times, even with some paper to it would be more snug - any other suggestions? It's brand new...
    09-15-08 08:15 PM
  4. jdmoises27's Avatar
    This same issue happened to me earlier today with my bold (which I just got today). It was working fine before & then out of nowhere, boom. I shut it on and off & it went back to normal. Not sure what the issue is, but I know I literally turded a brick.

    Hope that helps.
    09-15-08 08:36 PM
  5. JvKintheUSA's Avatar
    This same issue happened to me earlier today with my bold (which I just got today). It was working fine before & then out of nowhere, boom. I shut it on and off & it went back to normal. Not sure what the issue is, but I know I literally turded a brick.

    Hope that helps.
    Well I have a feeling I just got myself a $650 Blackberry Ipod..WTF!
    09-15-08 08:47 PM
  6. jdmoises27's Avatar
    Well I have a feeling I just got myself a $650 Blackberry Ipod..WTF!
    Send it back to RIM, especially if it's a Rogers. They have 1 year factory warranty.

    As far as I know, unlocking a phone doesn't void the warranty?

    Or you may want to try to call RIM?
    09-15-08 08:49 PM
  7. djboogie's Avatar
    Okay, so I got myself a new Bold from Rogers and unlocked it. Went to the AT&T store to get a SIM card, but once inserted it says on the top of the main screen "Insert SIM Card", and instead of signal strength bars I get "SOS". The guy in the store tried it with his SIM card and same issue. He inserted my new SIM in his IPhone and it worked, so it is not the SIM card. Any suggestions?
    hi, I had the same problem, i found out what happened, i used a toothpick to get the sim out from the back, and although i was gentle, there are components that sit RIGHT behind the sim reader, I accidently pulled one tiny cap from the board, wouldnt recognise sim cards then. I took it apart, soldered it back on (luckily i still had it , it hadnt fully come off) and it worked ok again
    its very tiny, and i would recommend a good solderer to do this for you, if indeed its the same as my issue
    03-03-09 05:40 AM
  8. Julian Machado's Avatar
    Thank you for your help!!! I have an old one and I fixed it by solding that tiny cap back! Thank you djboogie!
    04-02-13 08:31 PM
LINK TO POST COPIED TO CLIPBOARD