1. maxiang's Avatar
    I emailed a link to myself from my PC...couple of minutes went by and no vibe so I pulled my Bold from the holster to find it with a white screen. No prob, pulled the battery, started booting up, connected to network...then white screen again. Did this one more time and now...nothing I'm charging my battery on an external charger so I can try again later but, I think she's gone. Bought her off of ebay so no insurance, no warranty, no replacement. Total downer
    07-06-09 11:58 PM
  2. y0us3f's Avatar
    some ppl said wiping ur blackberry can fix alot of problems .. ? why dun u give it a try
    07-07-09 06:31 AM
  3. maxiang's Avatar
    UPDATE: The day after my first post she came on with the bad battery screen. New battery works like a charm

    Posted from my CrackBerry at wapforums.crackberry.com
    07-13-09 07:23 AM
  4. doomiberry's Avatar
    Happy for you!!!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-13-09 09:30 AM
  5. we3za's Avatar
    good on you mate

    there is nothing we cant fix with Blackberry
    07-13-09 10:00 AM
  6. Testingchip's Avatar
    Whew! Always nice when it's the simple stuff.
    07-13-09 11:11 AM
  7. maxiang's Avatar
    Amen to simple stuff! Thanks CB'ers! I'm thinking its time to get something with insurance now though

    Posted from my CrackBerry at wapforums.crackberry.com
    07-13-09 11:14 AM
  8. ericjackson28's Avatar
    Bam balam?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-13-09 11:27 AM
  9. maxiang's Avatar
    Ram Jam

    Posted from my CrackBerry at wapforums.crackberry.com
    07-13-09 11:31 AM
LINK TO POST COPIED TO CLIPBOARD