1. nfs2's Avatar
    I just got a bold on rogers, and i have it set to automatically connect to my home wifi as well as my work wifi. I know it does this because it shows the wireless network name at the top of the screen.

    But when i browse the internet, i think it still uses 3G for data. I tested this by going to an online IP checker, and it was different for my phone than it was for my laptop. The IP should be the same if my bold was on wifi.

    How do i set it to use wifi for data when it is connected?
    09-09-08 09:32 AM
  2. Reed McLay's Avatar
    It has better not be, IP address must be unique or the whole internet would collapse.

    When you have a Wifi connection, your device is assigned a IP address from a pool maintained by your router. The router actualy has the unique address and takes care of routing traffic to the selected device using it's own private address range.

    The only application that will use Wifi for data is your Browser. If you were able to subscribe to TalkSpot, you would also have Voice and network data through UMA.
    09-09-08 10:10 AM
  3. nfs2's Avatar
    It has better not be, IP address must be unique or the whole internet would collapse.

    When you have a Wifi connection, your device is assigned a IP address from a pool maintained by your router. The router actualy has the unique address and takes care of routing traffic to the selected device using it's own private address range.

    The only application that will use Wifi for data is your Browser. If you were able to subscribe to TalkSpot, you would also have Voice and network data through UMA.
    I understand this, perhaps i didn't explain it properly. If my Bold was using my home wifi, than my (external) IP would be the same as my laptop. (Because they are both going through my router).

    Because this is not the case, i know that my bold (even though it says its connected to my home network) is actually using 3G for data

    I hope this helps
    09-09-08 10:38 AM
  4. macgarnicle's Avatar
    In the browser, press the menu button and go to Options > Browser Configuration

    your browser is likely set to "Internet Browser". If you change it to "Hotspot" it will use the wifi

    Under Options > General Properties you can set what the default browser is. You may need to switch this back if youre not near a hotspot and trying to use the web.
    09-09-08 12:13 PM
  5. nfs2's Avatar
    In the browser, press the menu button and go to Options > Browser Configuration

    your browser is likely set to "Internet Browser". If you change it to "Hotspot" it will use the wifi

    Under Options > General Properties you can set what the default browser is. You may need to switch this back if youre not near a hotspot and trying to use the web.
    Thanks. I tried that just now, but it keeps reverting back to "internet browser".

    Could it be because i got this phone locked to rogers and they want to force me to use data?

    Whats the point of having a wifi device that doesn't let me use wifi
    09-09-08 12:33 PM
  6. macgarnicle's Avatar
    when you make the change, go to the menu and press the Save button if it doesn't prompt you to save before you exit the menu. If you're sure the changes 'stick', try restarting the browser and seeing if it works then.
    09-09-08 12:39 PM
  7. nfs2's Avatar
    when you make the change, go to the menu and press the Save button if it doesn't prompt you to save before you exit the menu. If you're sure the changes 'stick', try restarting the browser and seeing if it works then.
    I saved it but it reverts back to "internet browser" anyways
    09-09-08 12:44 PM
  8. Yuongn's Avatar
    that is weird because mine works perfectly fine. when i have my wifi turned on and connected to my home network... go start the browser and it automatically swaps to hotspot browser in options and uses the wifi. if wifi is off then it uses 3G internet browser. what OS are you using? i'm still using the original .125, everything works fine except for the slow java enabled browsing.
    09-09-08 12:49 PM
  9. nfs2's Avatar
    that is weird because mine works perfectly fine. when i have my wifi turned on and connected to my home network... go start the browser and it automatically swaps to hotspot browser in options and uses the wifi. if wifi is off then it uses 3G internet browser. what OS are you using? i'm still using the original .125, everything works fine except for the slow java enabled browsing.
    I'm on 125

    Did you buy your phone locked from rogers?
    09-09-08 12:57 PM
  10. sito's Avatar
    if you connect to your home wifi, does roger still charge you for data?
    09-09-08 01:01 PM
  11. nfs2's Avatar
    if you connect to your home wifi, does roger still charge you for data?
    No

    But i figured out my problem. The different IPs come from the fact that blackberry apparently routes all data (at least browsing) through their servers.

    So, even though i am going through my home router, the ip address is different than my other computers
    09-09-08 01:14 PM
  12. sito's Avatar
    No

    But i figured out my problem. The different IPs come from the fact that blackberry apparently routes all data (at least browsing) through their servers.

    So, even though i am going through my home router, the ip address is different than my other computers

    Is connection on home Wifi faster than roger network?
    09-09-08 01:29 PM
  13. Spazmogen's Avatar
    When you're surfing it should show WiFi in the top right corner.

    Try this: disable your radio and leave WiFi running. Surf. Notice what it says in the top right corner? WiFi.

    Enable 3G and disable WiFi. Surf. What's it say in the top right corner? 3G

    Now you know what to look for.

    or just sign up for the 6GB plan and don't worry.
    09-09-08 01:30 PM
  14. Spazmogen's Avatar
    Is connection on home Wifi faster than roger network?
    I believe so.
    09-09-08 01:31 PM
  15. durbin007's Avatar
    along those lines, i use Rogers for Blackberry pearl 8120 and for my home phone. When i'm home my blackberry is on wifi pretty much all the time, but that means when i get a call on it, it's using wifi to take the call, so it's not clear (my wireless modem is not that fast)....does anyone know how to have just your phone on rogers but data on wifi?
    09-09-08 01:49 PM
  16. macgarnicle's Avatar
    Just to clarify, since bringing it up in the Bold forum might confuse people: The Bold is not UMA compatible so you can't make calls from home with TalkSpot like with the Pearl.

    I believe you need a data plan to access many of the services (email, etc.). you should be able to still browse and use certain apps using only wifi though...Are you trying to get away without having a data plan?
    09-09-08 06:16 PM
  17. durbin007's Avatar
    sorry, my mistake in posting in the wrong area.
    what i want is when i'm home to have my phone operate on data only - like it would driving around....but all my data (email, surfin' etc) be on wifi.
    the problem is that my wifi modem isn't fast enough to process the call properly so it's not clear enough to work and it's a pain in the **** to turn off wifi everytime i want to make/take a call.
    thoughts?
    09-09-08 07:33 PM
  18. GMJeff's Avatar
    Actually, the "WiFi modem," as you may call it, should be able to transfer voice calls faster than data. Voice calls can be made clearly from 2400 baud modems, which are 80's technology. A WiFi stream, even if it was 802.11b (11Mbps) should still be able to handle UMA data and voice simultaneously without a problem. But, then again, maybe that's why they sell G routers that work at the 54Mbps standard for UMA.

    After looking at the 8120 user guide, it appears that if you want to stop the device from using UMA (WiFi) to make voice calls, you have to turn off UMA, which means that you lose your data connectivity over UMA, as well. You could just set up a WiFi connection manually on the Pearl to access data, instead.
    09-10-08 02:05 AM
  19. durbin007's Avatar
    thanks! appreciate the help.
    09-10-08 10:37 AM
  20. anon(1049620)'s Avatar
    Hey, I figured this one out...

    Go to Options -> General Properties and choose the Hotspot option THERE.

    Just tried it and I get my work IP address instead of BB IP address on whatismyip.com
    09-10-08 11:50 AM
  21. Dawg357's Avatar
    one little check you can perform just to force it over to WiFi just as a test to see what's what - - - Manage Connections - - turn off the Mobile Network completely and then turn on WiFi - then you'll no for sure that you are using WiFi - - not saying this is the answer to your dilema, but it helps just to test things and make sure you're connecting via WiFi and not the Network's 3g signal.
    09-10-08 11:56 AM
LINK TO POST COPIED TO CLIPBOARD