1. Canadianfreerider's Avatar
    Hey,

    I recently bought my first Blackberry Bold. It has a 507 error and a cracked LCD, but I got it for 100 bucks. I thought that it was a good deal if I could get it fixed. If I could not I will just sell it. I an trying to identify what model it is, and what Desktop manager I need to get. It has a flat black battery cover. When it powers on the screen is white with the cracks and black areas. Any help would be much appreciated. Here are the pictures.

    Last edited by Canadianfreerider; 08-18-09 at 07:23 PM.
    08-18-09 04:19 PM
  2. ausch's Avatar
    Just use DM 4.6 or 5.0 and try to load an OS on it. If it loads successfully, check eBay for a new LCD screen. You'll have to disassemble the Bold to check the model number on the back. Match that with the new LCD.
    08-18-09 04:47 PM
  3. Canadianfreerider's Avatar
    When I plug in the bold to DM 4.5 It does not recognize it. But my computer does. But when i plug in my old 7200 it is recognized. What should I do? Try DM 5.0?
    08-18-09 05:49 PM
  4. laollis's Avatar
    DM 4.6 should work
    08-18-09 06:08 PM
  5. Garz's Avatar
    Error 507 means there is no OS on the device. You just need to load the OS back on. DM 4.6 will work fine. if its a Rogers Bold 9000, you can go to there site to download it or just use this carriers official OS with step to install.

    http://forums.crackberry.com/f83/off...leased-251060/
    08-18-09 06:10 PM
  6. Canadianfreerider's Avatar
    I will update when i download and try DM 4.6


    Update.

    I installed DM 4.6 and still nothing.The manager says it is disconnected. My computer is still recognizing it though. Any suggestions?
    Last edited by Canadianfreerider; 08-18-09 at 07:14 PM.
    08-18-09 06:16 PM
  7. Canadianfreerider's Avatar
    anyone????
    08-18-09 07:33 PM
  8. jd914's Avatar
    Did you reboot your computer?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-18-09 07:37 PM
  9. Canadianfreerider's Avatar
    Yes. No response form DM. But the windows device manager is recognizing it.
    Last edited by Canadianfreerider; 08-18-09 at 07:48 PM.
    08-18-09 07:44 PM
  10. Canadianfreerider's Avatar
    I have read and followed the Blackberry 101: Reloading a nuked Blackberry guide, but i have run into a snag. When the application loader comes up, i have no os or applications to load. Do I need to download the Bold Os? Here is a pic: On the left is what is supposed to happen, right is mine screen.
    08-18-09 08:17 PM
  11. slite's Avatar
    Already posted...follow this link and it will tell you everything you need to do.

    http://forums.crackberry.com/f83/off...leased-251060/
    08-18-09 10:17 PM
  12. Canadianfreerider's Avatar
    Trying it now, hope it will work.
    08-18-09 10:36 PM
  13. Canadianfreerider's Avatar
    This is what i get when I try to update.


    Suggestions? Also under details in the app loader is says i currently have os 4.0 installed, if that helps at all.
    can anyone give me any help? Am I doing something wrong? Sould i go ahead and order a screen then try to fix the OS?
    08-18-09 11:00 PM
  14. dilipc's Avatar
    All the best! Keep us posted...
    08-18-09 11:00 PM
  15. dilipc's Avatar
    You should try with OS 4.6.0.282.
    08-18-09 11:52 PM
  16. Canadianfreerider's Avatar
    Thats the one i am trying to load.
    08-19-09 07:45 AM
  17. montage's Avatar
    There is a BB tool you can get for quickly loading software and OS files, doing backups etc. Have you tried this?

    I'll post the link when i get home if nobody else can remember where it is in the forum, i tried searching but can't find it.
    08-19-09 08:09 AM
  18. Jancy10's Avatar
    Go to C: drive>program files>common files>Research In Motion>Shared...when u see the OS folder right click send to compressed ZIP, save it to your desktop and extract the files, open up Apploader and select the extracted files from the OS highlight every .alx file and click open, dat shuld do it
    08-19-09 08:25 AM
  19. Canadianfreerider's Avatar
    That did not work, but I am probably not doing it correctly.
    08-19-09 08:58 AM
  20. Jancy10's Avatar
    That did not work, but I am probably not doing it correctly.
    Just keep tryin u'll figure it out, ur in da right track it takes a little to get it
    08-19-09 09:06 AM
  21. Canadianfreerider's Avatar
    When i try to load it using the loader, it says that there are no additional apps and it won't load.
    08-19-09 10:07 AM
LINK TO POST COPIED TO CLIPBOARD