1. jay-dawn13's Avatar
    So I've been using my blackberry bold 9900 for about two months now. Recently, in the last 5 days or so, the keypad and touchscreen don't work. Some days the keyboard works and the touch screen doesn't, and other days the touch screen works and the keyboard doesn't - which creates a huge issue as I can't even type in the password to unlock my phone on those days!

    Also, the apps on the homescreen light up as if I am touching them, when I'm not. And then random apps are opened, and commands are made without me directing it to do so (ie: calls are made to people randomly, or the calendar opens up and events times are being asked of me).

    Really, I have no control of the phone. On the days the keyboard doesn't work, if i hit the button on the top of the phone (keypad lock/unlock) it gets the keypad working for about a minute, before the phone starts spazzing again.

    - I've tried hitting alt+shift+del - nothing happened.
    - I've tried removing the battery (even over night) - it doesn't fix the problem.
    - I've even updated the phone to the newest OS, backed up my phone & restored it & removed all unnecessary apps - and it's still not working!!

    Please help!
    05-29-12 03:09 PM
  2. Elite1's Avatar
    Is there anything that coincides with the issues starting? A drop? A little water got on BB maybe?

    Also, do you use a holster? If so, do you notice the issues are typically when you just removed it from holster?

    Next time you have an issue, try double-clicking the top key to put BB into standby then back on.
    05-29-12 03:55 PM
  3. kazaka's Avatar
    Hi there.
    I'm experiencing the same exact problem.
    I'm getting crazy and realy mad with my bold. I realy do not know what to do. I think I've tried almost everything. My bold 9900 seems to have its own life (scary!!!).
    Any help would be highly apreciated.
    (My bold is originaly from ROGERS and I have the latest OS Roger has available to this phone - 7.1 Bundle 2108 (v7.1.0.746, Platform 5.1.0.546)
    02-22-13 05:08 PM
  4. kazaka's Avatar
    What can be the solution? Erase the flash and reinstal the os again?
    Can it be a keyboard problem?
    02-22-13 05:10 PM
LINK TO POST COPIED TO CLIPBOARD