View Poll Results: Have you had serious hardware or software issues that can be attributed to RIM?

Voters
49. You may not vote on this poll
  • No. Any problems I've had cannot be attributed to RIM

    39 79.59%
  • Yes. I had to seek outside help for repairs or software fixes.

    3 6.12%
  • Yes. I had to send my Bold to an outside company for repair.

    0 0%
  • Yes. My Bold had irreparable problems requiring that the device be replaced.

    4 8.16%
  • Yes, but the problems were caused by the carrier, not RIM.

    3 6.12%
  1. LuvMyBB's Avatar
    Just a quick, non-scientific poll about the frequency and magnitude of problems with the Bold. "Problems" would include such things as:
    * Device hardware quality problems
    * Manufacturing defects
    * Official OS problems
    * RIM (or other authorized) apps, such as ones you could get directly from RIM

    It should NOT include problems such as
    * Damage resulting from your ownership and use of the device
    * Operator error
    * Beta OS releases
    * Beta software
    * Rogue or junk 3rd party apps

    For the record, my first one had a bad WiFi radio. My replacement (a new one, not refurb) has been great.
    Last edited by LuvMyBB; 06-24-09 at 01:29 PM.
    06-24-09 01:21 PM
  2. Sith_Apprentice's Avatar
    06-24-09 01:22 PM
  3. LuvMyBB's Avatar
    Whoops sorry...didn't realize it was posted twice. Mods, please delete the first one! My bad!
    06-24-09 01:30 PM
  4. capitaaah's Avatar
    My bold has been trouble free for the 2 months I've had it.
    06-24-09 02:16 PM
  5. Jonneh's Avatar
    Not unless you count the ******** 3G/EDGE handoff from AT&T in my area. Pfft.
    06-24-09 02:19 PM
  6. Pure1rish's Avatar
    On my 2nd....RIM replaced my last one....

    Went Blank, Black, Dead...wouldn't do anything.

    I am very pleased with RIM and the product, Best Phone I have ever had, and I have carried unlocked phones from everywhere
    06-24-09 02:37 PM
  7. LuvMyBB's Avatar
    Not unless you count the ******** 3G/EDGE handoff from AT&T in my area. Pfft.
    Same thing here. I cross that line every workday of the week...very frustrating!
    06-24-09 02:40 PM
  8. rick458's Avatar
    Nope just a bit of user error and you guys are helping out with that
    06-24-09 02:57 PM
  9. MGV's Avatar
    First Bold:
    * Earpiece sounded twangy - even after OS changes
    * Mic would keep cutting out

    Second Bold:
    * LCD WSOD - replaced LCD

    Third Bold:
    * So far, so good
    06-24-09 03:34 PM
  10. username0022's Avatar
    No problems, unless you count the crappy original OS that came installed, which forced me to install new releases to fix old errors.
    06-24-09 04:20 PM
  11. spitothec's Avatar
    Frequently dropped calls until I upgraded the OS, and now awaiting the arrival of my replacement because of an internal short-circuit rendering my ringer silent.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-24-09 04:35 PM
  12. ak29's Avatar
    No problems so far, but, Ive only owned it for a little over two months.
    06-24-09 07:31 PM
  13. si_chindo's Avatar
    So far so good. I've had it 2 mths and no complaints. Best phone I've ever had!

    Posted from my CrackBerry at wapforums.crackberry.com
    06-24-09 07:52 PM
  14. xDAKx's Avatar
    The only issue I have on my Bold is that my Standby/Mute button on the top of the phone doesn't seem to work at all. It won't mute calls, and it also wont' put the phone in standby.
    06-24-09 08:08 PM
  15. K B's Avatar
    Only issue I have with my Bold is that I smoke it all day long. Total addict.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-24-09 09:46 PM
  16. arashb's Avatar
    None really, AT&T 3G reception sucks but what's new?
    06-25-09 02:18 AM
  17. Teek's Avatar
    None. Only AT&T 3G/call failed issues.

    My Bold is perfect
    06-25-09 03:05 AM
LINK TO POST COPIED TO CLIPBOARD