1. big_time2's Avatar
    I've had my Gmail email address on my BlackBerry for a few years now. If I would get an email and read it first on my device, the email would still show as unread if I checked on my computer. The same occurred vice versa, if read on my computer I still needed to mark it read on my device. Which was not a problem because I normally don't get too many emails.

    A couple of days ago I added a second Gmail address on my Bold 9700 and was sending/receiving emails normally. Today, I log on to my email on a computer and all these emails for the past two days are showing as read. If emails were deleted on the device they were deleted on my computer as well. I tried sending a test email, and read it on the device and it updated as read on the computer within a couple of minutes. Which is good, now I don't have to mark read emails on both my computer and my device.

    The problem that I have now is the email address that I had on my phone for a few years I still have the same problem. If an email is read on my device I still have to mark it as read on my computer and vice versa. This only happens on the email address I've had for a few years.

    I tried removing the old email address and re adding it, didn't help. Sent service books, didn't help. A battery pull, didn't help.

    Is anyone else having this problem? Anyone know how I could get the old email address to do the same thing as the new one I just added recently?
    01-02-10 10:11 PM
  2. noaim's Avatar
    are you sure its setup as imap on the computer? if its set up as pop it wont work
    01-02-10 10:29 PM
  3. big_time2's Avatar
    So POP should be disabled?
    01-02-10 10:37 PM
  4. Paul S's Avatar
    Yes, it works on pop email.

    Using POP on multiple clients or mobile devices

    If you're accessing Gmail on multiple clients through POP, Gmail's 'recent mode' makes sure that all messages are made available to each client, rather than only to the first client to access new mail.

    Recent mode fetches the last 30 days of mail, regardless of whether it's been sent to another POP client already.

    Setting up 'recent mode'

    In your POP client settings, replace 'username@gmail.com' in the 'Username' or 'Email' field with 'recent:username@gmail.com'

    Once you enable recent mode, please be sure to configure your POP client to leave messages on the server according to the instructions below:


    * Outlook or Outlook Express: on the Advanced tab, check the box next to 'Leave a copy of messages on the server.'
    * Apple Mail: on the Advanced tab, remove the check next to 'Remove copy from server after retrieving a message.'
    * Thunderbird: on the Server Settings tab, check the box next to 'Leave messages on server.'
    01-02-10 10:41 PM
  5. big_time2's Avatar
    Setting up 'recent mode'

    In your POP client settings, replace 'username@gmail.com' in the 'Username' or 'Email' field with 'recent:username@gmail.com'

    Once you enable recent mode, please be sure to configure your POP client to leave messages on the server according to the instructions below:
    I just deleted the email and re-added it as recent:username@gmail.com and it worked.

    Thanks. Appreciate your help.
    01-02-10 11:00 PM
  6. Paul S's Avatar
    Sweet. Glad to help.
    01-02-10 11:07 PM
  7. Terry Johnson4's Avatar
    I was able to replace a setup username with recent:username@gmail.com on my computer. But on my android phone is another story. The username is greyed out so how do I change it? And if I setup a whole new account with the recent: part in the username, it says invalid username or password. So how to get beyond this?
    07-04-13 08:12 PM
LINK TO POST COPIED TO CLIPBOARD