1. justinbasini's Avatar
    I have now tried for hours to fix the following issue. I have read lots of useful posts on this subject but to no avail. Please help me.

    I want to be able to DISABLE the firewall on my Blackberry Bold.

    I have used JML Commander many times to wipe the BB of any IT policy. This works fine and allows me to disable the firewall.

    Then I attach the BB to my computer running Desktop Manager 5.0 (set up for internet not corporate email). And even without doing ANYTHING but just plugging the BB into the laptop the Firewall becomes instantly ENABLED AND LOCKED. To be clear I don't need to download anything to the device, restore a back up or sync, as soon as it get plugged in the Firewall becomes ENABLED AND LOCKED.

    I have tried uninstalling the Desktop Manager and then reinstalling a clean copy from the BB website and it still keeps happening. Unfortunately I need to be able to sync with my laptop otherwise I'd just not sync it.

    What do I need to do to stop this Firewall being put into enabled and locked mode everytime I connect the Bold to DM running on my WIndows Vista HP laptop?

    Thanks for any help.
    08-18-09 05:04 PM
  2. whwv's Avatar
    I have the same problem. I want to disable the firewall so I can use apps for Slacker Radio and WordPress. I get the error message "The application has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your IT Policy."

    So, reading the other posts, I did the reset to factory as suggested. This works fine, until I connect the BlackBerry to my computer and use Desktop Manager. I have uninstalled Desktop Manager, reinstalled and then done the factory reset and it still locks the firewall once I sync it again.

    Any ideas how I can keep Desktop Manager from locking down the firewall?

    My phone used to be on the BES, but now it is not.

    Thanks!
    09-09-09 01:30 PM
  3. justinbasini's Avatar
    Update on my original post.

    After two weeks of trying everything I could think of I gave up on this. After extensive research I couldn't find a way of not having some options (including firewall) out of my control upon connecting my blackberry to my laptop.

    Therefore I decided not to ever connect my Blackberry to my computer but rather solve for calendar syncing through Google Calendar and Google sync. This works fine. I can download and install third party apps through Blackberry App world on OTA so that is fine too. Suppose the only risk I run is no ability to back up but that's a fine compromise to have a Blackberry that I can do what I want with.

    Thanks

    Justin
    Last edited by justinbasini; 09-14-09 at 07:52 AM.
    09-14-09 07:49 AM
  4. brandnewsimmy's Avatar
    The only thing I can think of is to try and use the blank IT policy posted somehwere here about how to remove and IT policy. If you have already tried that, I'd make sure to delete the policy.bin as well as the reg edits... I don't know if this will help but hopefully. I just did battle with an IT policy myself. So good luck!

    Posted from my CrackBerry at wapforums.crackberry.com
    09-14-09 02:02 PM
  5. danifunker's Avatar
    I would follow brandnewsimmy's response, and also entirely wipe out your blackberry configuration on the PC.

    (Vista / Win7) = Delete %userprofile%\AppData\Roaming\Research In Motion folder

    Windows XP = Delete %userprofile%\Application Data\Research in Motion folder

    (It might be in Application Data, or Local Settings, I haven't used XP in a number of years...)

    Good luck!
    09-14-09 05:06 PM
  6. whwv's Avatar
    Update:

    Thanks for the ideas, I think removing those folders may have done it! I completely uninstalled anything from my computer relating to Research In Motion. I then deleted the directory mentioned above, as well as the RIM application directory. It might be worth noting that the RIM app directory still contained a file called pool.bin after the uninstall. I'm not sure if that was one of the files I put in there when I was trying to reset the IT policy earlier, but I trashed it just in case.

    I installed the latest version of the Desktop Manager from RIM's website, and then ran loader.exe \resettofactory just like normal. Once the reset was completed the IT policy was gone, but this is where I was before. Just to reiterate, my problem is not removing the policy, but keeping the policy from reapplying once I sync the device for contacts and calendar.

    Well, I'm happy to say that after three syncs so far the policy has not reapplied itself. If you are in the same situation here are the steps I followed which seems to be working.
    1. Uninstall all RIM applications
    2. Perform a search for "Research In Motion" directories and delete them all
    3. Download the latest Desktop Manager from RIM
    4. Perform a factory reset(from the command line, run "loader.exe \resettofactory" located in "C:\Program Files\Common Files\Research In Motion\AppLoader")
    5. Sync everything back up and you should be good to go!


    Since I can't hyperlink instructions for the factory reset (<10 posts), the most concise way that I noticed was here: forums.crackberry.com/f5/master-reset-2566/#post2220800
    Last edited by whwv; 09-28-09 at 04:56 PM. Reason: typo
    09-28-09 04:55 PM
  7. roccos_van's Avatar
    I realize this thread is almost a year old but I bought a bold of craigslist for my wife and that exact thing happened.

    I followed the steps exactly in the post above except with #4 I used crackutil to remove the IT policy, and it worked! Now I can connect to DM without worrying about the IT policy getting turned back on!

    Thank you very much.
    Last edited by roccos_van; 06-19-10 at 06:55 PM.
    06-19-10 06:53 PM
LINK TO POST COPIED TO CLIPBOARD