1. JewJuice's Avatar
    ***I now see the other threads that explain this. Sorry for the redundancy...***

    I changed the input language to Spanish by accidentally hitting ALT + ENTER. I switched the imput language back to English and deleted Spanish from my phone. Now everytime I type the "EN" icon shows up in the top right corner of my display. How can I get rid of that? It's annoying!!
    Last edited by JewJuice; 03-18-09 at 05:44 PM. Reason: Didn't see other threads when I searched originally
    03-18-09 04:10 PM
  2. bt224's Avatar
    Sad news, you will have to wipe and reinstall to get rid of it. Bizarre, but true.
    03-18-09 04:12 PM
  3. skyrider007's Avatar
    If you have a backup file from before the EN icon have appear then simply go to Advanced Restore and restore "Language Input Selection". That will fix it for you.
    03-18-09 05:16 PM
  4. JewJuice's Avatar
    If you have a backup file from before the EN icon have appear then simply go to Advanced Restore and restore "Language Input Selection". That will fix it for you.
    AWESOME!! Hopefully that will save me from having to wipe. I will try that as soon as I get home.

    Thanks a lot!
    03-18-09 05:40 PM
  5. JewJuice's Avatar
    SUCCESS!!!
    It's "Input Method Switcher Option"... Cleared it and restored it from my backup data. You are a genius!
    03-18-09 11:43 PM
  6. skyrider007's Avatar
    SUCCESS!!!
    It's "Input Method Switcher Option"... Cleared it and restored it from my backup data. You are a genius!
    Congrats
    03-19-09 04:24 AM
  7. jshaffer75's Avatar
    Hmmm I tried this and it worked until I rebooted the phone. Did I do something wrong? Maybe someone can put a step by step guide in here? Not sure why it came back up after the reboot.
    03-19-09 03:56 PM
  8. janx's Avatar
    anyway to clear it if you have no back up data?
    03-19-09 04:09 PM
  9. curlin31's Avatar
    If you have a backup file from before the EN icon have appear then simply go to Advanced Restore and restore "Language Input Selection". That will fix it for you.
    This worked for me as well, thanks much!
    04-21-09 05:32 PM
  10. gipfeli's Avatar
    i've read this about 15 times and i can't make sense of this: "If you have a backup file from before the EN icon have appear then..."

    i have a backup file from .167... but never made one for .247
    04-21-09 05:50 PM
  11. riiich's Avatar
    I switched language today and needed a solution for EN icon. Can't wait to get back to try this!
    04-24-09 03:28 PM
  12. Hwaiting's Avatar
    I did a backup and it worked for a short while and then the dreaded EN came back.

    The only way I got rid of it was to do a complete wipe: Options > Security Options > General Settings > Blackberry Button and select "Wipe Handheld". This wipes all user data and returns it to what it was like straight out of the box (it keeps whatever OS is on there though if you upgraded).
    04-24-09 06:15 PM
  13. jonchos's Avatar
    As for OS 5.0 this can easily be changed: options -> language -> language ID (automatic/show -> hide)
    07-19-09 09:14 PM
  14. y0us3f's Avatar
    Congratz bro.

    is it that annoying ?

    i like it to see if im in numbers mode or en or arabic
    07-19-09 10:11 PM
  15. aanzola33's Avatar
    I can't believe i didn't try doing the advance restore before, but it worked!

    that's the last time i mess around with my bold for the sole purpose of seeing arabic words :P
    07-19-09 11:59 PM
LINK TO POST COPIED TO CLIPBOARD