1. Vix's Avatar
    Just upgraded to .656 and now I don't get confirmation of text messages being delivered. I've set and saved the settings to ON, but its flicking back to OFF.

    Is anyone else having this issue? I'm going to roll back to my previous OS as it worked fine on there..
    05-29-10 08:38 AM
  2. jshuford's Avatar
    My install of v.5.0.0.680 is working...
    05-29-10 08:42 AM
  3. fatboy97's Avatar
    Is this from a Cell Phone Provider that you have received confirmations before??? I know some provider's are not compatible with others and you will not receive confirmations.
    05-29-10 08:46 AM
  4. c_86's Avatar
    some carriers support this feature, others dont... its kinda like a BBM thing where it shoulds it been delievered... like i said some carriers support it, some do not...

    OP have you tried a battery pull? (with the device on take the battery out for 20 seccs and replace(put batt back in))
    05-29-10 09:31 AM
  5. Vix's Avatar
    I've used this feature from day one of owning my phone.. and through various upgrades too. This is the first one that has stopped it working..

    Done a battery pull, sent a message, got a 'D' next to the message, sent another message, no report and the option has been switched to off again

    Will try .680, hadn't spotted that one!
    05-29-10 11:48 AM
  6. fatboy97's Avatar
    I've used this feature from day one of owning my phone.. and through various upgrades too. This is the first one that has stopped it working..

    Done a battery pull, sent a message, got a 'D' next to the message, sent another message, no report and the option has been switched to off again

    Will try .680, hadn't spotted that one!
    Go to the main 9700 forum and look up... it's a STICKY thread at the top... http://forums.crackberry.com/f146/ne...-680-a-472990/
    05-29-10 12:12 PM
  7. MobileMadness002's Avatar
    The only thing it would confirm is deliver to the SmS delivery system. Not to the recipient.
    05-29-10 12:14 PM
  8. jshuford's Avatar
    I don't know if it is carrier related...my current install is Hutchinson whatever and I really don't know who they are.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-29-10 12:14 PM
  9. c_86's Avatar
    by carrier related that means AT&T.... the OS being from hutchinson doesnt matter... its the network your currently on (in this case for example AT&T) is what dictates whether its supported or not...

    for example, my carrier rogers, does not have this feature but telus does... now if i use a rogers OS on my telus device, it will still work because its a feature telus supports... make sense?
    05-29-10 12:21 PM
  10. Pete6's Avatar
    Options, SMS, Delivery Report = On.

    Some carriers do not offer this.

    A call to your carrier may help.
    05-29-10 01:53 PM
  11. Vix's Avatar
    Let me re-explain the situation!!

    1) I've been using the delivery reports feature since I got the phone in December, been working fine! I know for a fact Vodafone offer it - they always have done!

    2) I know how to turn it on/off, but when I turn it on it does a delivery report for the next message I send, then the next message AFTER that one doesn't get reported and the feature has been turned off.

    So I'm now upgrading to .680 to see if this works .. its not that I don't know where to turn it on, or that my carrier doesn't offer it. Since my last upgrade its not staying turned on basically!
    05-29-10 05:49 PM
  12. c_86's Avatar
    yup, try upgrading... if it doesnt work, please report back good luck
    05-29-10 05:51 PM
  13. Vix's Avatar
    All fixed Normal service is resumed.

    Did a clean install of .680 and delivery reports are sticking around after each message!!

    *phew*
    05-30-10 07:02 AM
  14. c_86's Avatar
    woooohooooooo!!! glad to hear upgrading worked!
    05-30-10 08:46 AM
  15. gameson's Avatar
    Options, SMS, Delivery Report = On.

    Some carriers do not offer this.

    A call to your carrier may help.
    I m using 680 build with AT&T phone. How come I don't see this in my options?

    Thanks.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-10 08:57 AM
  16. Pete6's Avatar
    I m using 680 build with AT&T phone. How come I don't see this in my options?

    Thanks.

    Posted from my CrackBerry at wapforums.crackberry.com
    I too am running .680.

    It is like I tried to say to the OP, not all carriers offer this. You may need to call them.

    The OP's problem was almost certainly either a Service Book issue or (very unlikely) a corrupted OS.

    It is fixed now and I am glad for him.
    05-30-10 09:02 AM
  17. gameson's Avatar
    I too am running .680.

    It is like I tried to say to the OP, not all carriers offer this. You may need to call them.

    The OP's problem was almost certainly either a Service Book issue or (very unlikely) a corrupted OS.

    It is fixed now and I am glad for him.
    So you are saying if other carriers offer this, the option will suddenly pop out? I m using AT&T service as well

    Thanks.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-10 09:05 AM
  18. c_86's Avatar
    Yes, if the service is support by the carrier then it will be in your options to enable or disable it... and obviously if the carrier doesn't support it, the option will not be there (regardless of what build of OS you are using, as i believe its sent via service book)
    05-30-10 09:08 AM
  19. Pete6's Avatar
    There are several ways of implementing this.

    My 9700 is unbranded so I tend to see all the options. This is handy in my role here.

    - some carriers implement such functions via a a keyboad sequence i.e. *N#
    - some carriers use a menu choice like I have on my phone.
    - some use a website setup
    - some need you to call them to enable SMS delivery reports.
    05-30-10 09:15 AM
  20. Vix's Avatar
    It is fixed now and I am glad for him.
    The him you refer to is actually a her..
    05-30-10 03:34 PM
  21. Pete6's Avatar
    The him you refer to is actually a her..
    My apologies, I did wonder from your previous responses. However since the issue was not decided, I continued anyway.

    My goal was the resolution of your BlackBerry's problem.
    05-30-10 03:39 PM
LINK TO POST COPIED TO CLIPBOARD