1. themandan40's Avatar
    Yesterday I had my phone in my back pocket. When I pulled it out to check the time the phone was off and the red LED was lit up. I pulled the battery and re-inserted it. Nothing. After repeated attempts I still had nothing.

    After about 1 hour of waiting I got it to boot up for about 3 minutes then the screen slowly faded to a washed out version of my home screen and froze there. Pulled battery and re-inserted. Nothing.

    After almost 24 hours I have gotten the phone to boot up 2 times. The longest being about 20 minutes ago after all night of sitting. It stayed on for about 5 minutes and then died. The battery was fully charged yesterday before dying and the battery level read 86% when I did get it to turn on.

    Unfortunately I bought this phone used and don't think T-Mo will do anything for me if I asked them about it.

    The water stickers are still bright white and it doesn't seem to be damaged anywhere. I didn't drop it and have never dropped it. I have had it for about a month with no problems at all.

    Any info/advice would be great.
    07-24-11 07:26 AM
  2. blackberry-unlocking710's Avatar
    It can be many things but one of them can be a battery issue.

    Take your battery and try to use it with other device... if it will show the same as goes with your Blackberry you will know for sure that it's a problem with the battery.

    then just replace it with a new one. if it's something else.. well i would take it to the repaid shop to see what is the damage.
    07-24-11 09:48 AM
  3. ncpete's Avatar
    Your problem sounds exactly like my 8900 behaved when I had a bad/die-ing battery. If a friend has a 9780, swap batteries, and see if his battery makes your 'berry work right, and if his acts screwy now.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-24-11 10:24 PM
  4. starchit's Avatar
    I agree with the other posts. However, you said you had it in your back pocket. It's also possible that too much pressure was applied to the screen causing damage. Hope it's just the battery.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-25-11 06:59 PM
LINK TO POST COPIED TO CLIPBOARD