1. ThirstyTurtle's Avatar
    I have my gmail account linked to my blackberry, not through the gmail application, but through the email thing. Anyways, if I go to "Compose Email" and send an email to someone, it NEVER goes through. It will put a check mark next to it like it's been sent but they'll never get it. Now if someone sends me an email and I hit "Reply" and send them one back, they get it right away. What the heck?! Please help me out, my emails almost useless right now, I have to save at least one message from everyone I want to send an email to, then reply to that message every time, it's incredibly aggravating. And o ya, if it helps, i have the Gmail setup through BIS in the way so that it's truly push email. thank!
    12-19-08 07:10 PM
  2. Duvi's Avatar
    Truly push? I believe it does that already.

    I would delete the email account and re-add it.
    12-19-08 07:36 PM
  3. Mode's Avatar
    Try re-sending your Service Books to your BB.
    12-19-08 07:47 PM
  4. ThirstyTurtle's Avatar
    Try re-sending your Service Books to your BB.
    How do I do that?
    12-19-08 08:29 PM
  5. Morganizer's Avatar
    How do I do that?
    It's an option on the BIS site when you log in.
    12-19-08 09:38 PM
  6. SmashFace's Avatar
    Silly question, but do you have a Data plan? If you don't, you obviously need one.

    If you do - check to see what email address you're sending it from. By default, your BB will send everything from your @carrier.blackberry.net address. If you haven't set that up yet, you won't be able to send anything. If you're replying, you're using the Gmail smtp to send things which is why it is working.
    12-19-08 09:57 PM
  7. ThirstyTurtle's Avatar
    Silly question, but do you have a Data plan? If you don't, you obviously need one.

    If you do - check to see what email address you're sending it from. By default, your BB will send everything from your @carrier.blackberry.net address. If you haven't set that up yet, you won't be able to send anything. If you're replying, you're using the Gmail smtp to send things which is why it is working.
    okay, yes I have a data plan of course. But the other might be my problem, I do not have a blackberry.net address setup, but let's say i set one up, then where do I change it to send from my gmail by default?
    12-19-08 11:57 PM
  8. ThirstyTurtle's Avatar
    Try re-sending your Service Books to your BB.
    Thanks! This did it:0)
    rktate likes this.
    12-20-08 12:17 AM
  9. Mode's Avatar
    ... and there was much rejoicing!

    rktate likes this.
    12-20-08 01:01 AM
  10. mbopy22's Avatar
    Hi
    Sorry to revive this old post. But I have the same problem. I cant compose and send emails with my gmail nor my hotmail accounts linked to my BlackBerry.
    Yes I do have BB data plan.

    Every time I compose an email and try to send it, I can only get 2 options: 1 Save Draft, 2 Full Menu. It does not give me the SEND option at all. I can however reply to any email.

    Ive already did the whole sending Service Book thing, and NOTHING. I also deleted and re assigned the emails, and NOTHING. And of course I did try the pulling out battery restart system, with no luck either.

    Any help????
    08-25-11 12:51 AM
  11. mbopy22's Avatar
    Nevermind Ive fixed. Had to wipe the phone completely and now is working fine.
    08-25-11 10:36 AM
LINK TO POST COPIED TO CLIPBOARD