1. Bigsean72's Avatar
    when someone send me a text or MMs they Name dose'nt show up only the contact's phone number.can someone please help,this will be the second time I take this 9700 back and get another one cause of this problem-
    Last edited by Bigsean72; 11-27-09 at 04:09 AM.
    11-27-09 04:06 AM
  2. pooprajoe's Avatar
    could be a few problems, one is if you have the contacts saved to your sim card they won't show, they will only show the name if they are saved to the phone, also sometimes I've seen where you have to save the phone number as an 11 digit 1-area code-phone number, also best way to see if there is a problem with the phone is to delete a contact completely, then save the contact with first and last name and 11 digits and test. if problem still occurs then it's either some random setting, I wouldn't bring the phone back for this reason as it usually is simple to solve, plus if you do a backup/restore from previous phone with same problem if it's a setting you'll just keep restoring the problem to the new phone.
    11-27-09 04:19 AM
  3. finz72's Avatar
    Same issue here. By what I understand, it's a known issue. My contacts are on my phone and I have the issue. I've heard that all your phone numbers must not have - or (xxx) and that they should be all together like this ..11234567890
    Look at the forum, you'll see other posts the same.
    11-27-09 05:57 AM
  4. clitrenta's Avatar
    Same issue here. By what I understand, it's a known issue. My contacts are on my phone and I have the issue. I've heard that all your phone numbers must not have - or (xxx) and that they should be all together like this ..11234567890
    Look at the forum, you'll see other posts the same.
    This is exactly right. There have been a lot of posts on this issue. Just look
    11-27-09 09:08 AM
  5. r.santa1's Avatar
    Go to option generql options and put yes for display name. In sms screen.

    Simple.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-27-09 09:18 AM
  6. migster's Avatar
    i am new to the BlackBerry community and also to the phone product. I love it! Anyhow, i had the same problem when texting one of my buddies.

    Solution: Based on a previous reply posted. i did delete the contact and re-entered his info. I am able to see his name when texting now. I think the reason for that was because i saved the contact somewhere outside of contacts on phone.

    I was able to verify the other contacts did show on texting. I also verified that the other contacts did have the hyphens: XXX-XXX-XXXX. I re-added my buddy contact that i was having the issue with and put his phone format w/out the hyphens. So, i do not think it matters whether dashes are in this format or not.

    I hope this helps.
    12-30-09 11:52 AM
  7. syb0rg's Avatar
    http://forums.crackberry.com/f146/bl...ms-bug-378483/

    Posted from my CrackBerry at wapforums.crackberry.com
    12-30-09 11:58 AM
  8. tihman2g7's Avatar
    what you have to do is ...edit the contact number by adding his or her country code to the number and go back to your message to check wether is working........!!!!! thanks and enjoy your day!!!!!
    05-16-13 12:40 PM
LINK TO POST COPIED TO CLIPBOARD