1. Honeydee876's Avatar
    HELP!!!! i recently got the tmobile unlimited talk text n web and i have an unlocked bold 9000 blackberry phone. everything works on it, my bbm and all BUT my internet browser. everytime i go on it, it keeps saying it needs wifi. I called t mobile support and they say everything is working fine from their system to mine. and then i spoke to blackberry support for over an hour and they end up telling me, the bold phone is not supported by tmobile for the internet...
    IM SURE SOMEONE FROM HERE HAVE THE SAME PROBLEM AND KNOWS THE SOLUTION....CAN SOMEONE PLEASE HELP REPLY WITH STEPS TO STEPS ON DOING IT??? I REALLY NEED MY WEB BROWSER SO I CAN KEEP UPDATES ON MY EMAILS FOR WORK WHEN IM ON THE ROAD...PLEASE ANYONE HELP?
    07-30-11 06:51 AM
  2. delfteo's Avatar
    It' simple you miss a part from your service book.
    Enter your options menu choose advanced options enter host routing table press bb menu button en choos "register now"
    You will receive your service books when not call your company and ask them to send your service book. After this you start your browser enter options enter general properties and choose for default browser "internet browser"


    Enjoy DelftEo


    Posted from my CrackBerry at wapforums.crackberry.com
    07-30-11 07:40 AM
  3. saudadeii's Avatar
    I have an AT&T Bold 9000 on TMobile and the browser works fine.

    You can resend service books using TMO's, web site. Have you created an account on it yet?
    07-30-11 09:04 AM
  4. Honeydee876's Avatar
    i did that register now thingy so much times...i have 12 entries under the service book status....i called both the blackberry n the tmobile...and they be saying it not supported...and u know dat aint true..someone must know how i can fix this...
    07-30-11 09:11 AM
  5. Honeydee876's Avatar
    saudadeii@ tell me more...create what account? how did u get it to work?
    07-30-11 09:11 AM
  6. Honeydee876's Avatar
    delfteo@ the problem is, the browser stays on hotspot..and it cant change in any way...
    07-30-11 09:13 AM
  7. delfteo's Avatar
    delfteo@ the problem is, the browser stays on hotspot..and it cant change in any way...
    That's because you don't have the "internet browser" settings in your service books.
    See if you have this in your service books
    "BlackBerry Internet Service - Browsing [BrowserConfig]"
    Download the opera browser at http://m.opera.com and if your apn settings are oke you will see that you can browse the net easy.
    Opera don"t use your service books

    Enjoy DelftEo


    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by delfteo; 07-30-11 at 09:37 AM.
    07-30-11 09:27 AM
  8. blackberry-unlocking710's Avatar
    did you make the service book update on your unlocked blackberry bold 9000?
    07-31-11 10:04 AM
  9. saudadeii's Avatar
    saudadeii@ tell me more...create what account? how did u get it to work?
    On T-Mobile.Com. Go to the signup page and register for My Tmobile.

    I had an issue with email when I first activated because my PIN was not correctly registered. I called TMO support and got escalated to the Blackberry team and we got it fixed. When you spoke to Blackberry support, was it TMO's BB team, or was it RIM direcly?

    When you activate a TMO provided Blackberry, they already have the PIN in the system. When you use a different carrier's, then PIN doesn't always synch up properly.

    I've had this setup for nearly a year and a half.

    FYI: You won't get 3G
    07-31-11 12:07 PM
LINK TO POST COPIED TO CLIPBOARD