1. a_lleras's Avatar
    Hi, I have a, lets say, "rescued" bold 9000, it's completely dead, when I connect it to the PC it won't show the red light and I hear someting like a buzz sound coming from the earpiece. I already tried the "Memory fix" and some other things, but there's a catch. I still don't have the battery, so I'm (prematurely) asking for any clues and haven't tried anything with the battery (with some of the methods I read that It would work after putting the battery in),but, it just seems weird for it not to be doing anything.

    What do you think?

    Thanks!
    05-07-12 04:52 PM
  2. KBBU's Avatar
    I tried this "removing and replacing small battery" fix and initially it didn't work with my device. That's when I noticed that the housing screws on my device are loose. Took just a bit of tightening and viola - my device is working again!

    So, you may want to check if you have any loose screws (on your device, I mean! ), just as I had some (on my device, I mean!). Hopefully a T4 (or T5) screwdriver is all you need to make it work in conjunction with the 'small' battery fix.

    Leave some feedback after trying to tighten those screws, please.
    06-01-12 09:54 PM
  3. Wickedjov's Avatar
    i have a problem similar to this , but it's on a curve 9360
    10-22-13 05:09 PM
LINK TO POST COPIED TO CLIPBOARD