1. joseraulnova's Avatar
    OK ive had my bold for a while, and after 2 weeks of no use (vacation) there are several keys that got "stuck" or "sticky". And theyre next to each other: Y, U, I and the Back key.

    They simply dont click and I have to press them REAL hard to type those letters its so annoying anyone knows what couldve caused this? how can this be fixed?

    im thinking on buying a new keyboard... please help me guys and thanks for the support!
    06-18-09 12:58 AM
  2. Tronyx's Avatar
    I don't get how you could not use your Bold for two weeks, lol. If you're within your warranty, exchange it. If not and you have insurance, you could swap it for a refurbished one or you could buy a new keypad and swap it yourself.

    Chris
    06-18-09 01:01 AM
  3. mustu's Avatar
    exactly I dont know how you cant use it... my bold is with me all the time...

    Its been my first berry and I always plan to use a BB from now on!
    06-18-09 06:32 AM
  4. charlie100's Avatar
    If you have to ,take the key pad out and inspect.Propably needs a clean ,sounds like there's some liquid in there

    Posted from my CrackBerry at wapforums.crackberry.com
    06-18-09 04:04 PM
  5. PwnCakes193's Avatar
    Try using a dry toothbrush. Hold you Bold upside down and run the bristles in between the keys

    Posted from my CrackBerry at wapforums.crackberry.com
    06-18-09 04:34 PM
  6. Scotty2032's Avatar
    You could also try one of those air cannisters or just put in a new one. It was fairly easy, I got it from cnn.cn
    06-18-09 06:33 PM
LINK TO POST COPIED TO CLIPBOARD