1. zd1996's Avatar
    i really don't want to have to downgrade because i really like .600 but my battery wont even get me through the day anymore, any way i can stop my battery from draining so quickly, thanks in advance
    07-16-11 10:17 PM
  2. npunk42's Avatar
    Do you have an old battery? As they age they dont hold the charge as well. By chance if you upgraded from the Tour, you might switch batteries and see if that one is better. I have the 2600 seidio extended battery, but I didnt notice any change in discharge after the OS upgrade.
    07-16-11 10:20 PM
  3. zd1996's Avatar
    Do you have an old battery? As they age they dont hold the charge as well. By chance if you upgraded from the Tour, you might switch batteries and see if that one is better. I have the 2600 seidio extended battery, but I didnt notice any change in discharge after the OS upgrade.
    i had a tour and switched batteries with it because my bold was older, so it has a new battery inside
    07-16-11 10:22 PM
  4. Spencerdl's Avatar
    I haven't notice a quicker battery drain with .600, if anything I'm getting a few more hours of usage. You can have your battery check at your local carrier store. Sometimes batteries just deteriorate and need to be replaced
    jaydee5799 likes this.
    07-16-11 10:52 PM
  5. zd1996's Avatar
    I haven't notice a quicker battery drain with .600, if anything I'm getting a few more hours of usage. You can have your battery check at your local carrier store. Sometimes batteries just deteriorate and need to be replaced
    maybe its just me, thanks anyways
    07-16-11 11:27 PM
  6. eve6er69's Avatar
    Maybe something isn't sitting well. Have you tried wiping the phone and reloading the os?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-11 11:34 PM
  7. SCrid2000's Avatar
    I haven't had such a great time with 600. Try 587. Oh, new OSBB hybrid coming soon

    Sent from my NookColor using Tapatalk
    07-19-11 12:35 AM
  8. disturbed10890's Avatar
    How long have you had the os on, and how many batt pulls have you done?? It takes a little while for it all to settle in, and start functioning properly again.
    07-21-11 09:02 AM
  9. lunatyck's Avatar
    I'm not sure if you have done this already, but make sure things like bluetooth and wifi are turned off. Also, make sure you don't have apps running in the background as well. Pressing the exit key doesn't turn off the app. If you hold the menu button, you will have a bar of all your running apps. Press the menu key when you're in the app and press close (or exit) to fully turn them off.

    Good luck
    07-21-11 10:52 AM
  10. pcgizmo#IM's Avatar
    How long have you had the os on, and how many batt pulls have you done?? It takes a little while for it all to settle in, and start functioning properly again.
    What exactly doesn't function properly?

    I'm not sure if you have done this already, but make sure things like bluetooth and wifi are turned off.
    WiFi is not a battery drainer, the mobile network drains the battery far more than leaving wifi on constantly.
    Last edited by pcgizmo; 07-21-11 at 11:00 AM.
    07-21-11 10:56 AM
  11. papped's Avatar
    I had some issues with .600, not necessarily battery drain, but other things so I didn't have it on long enough to really check battery life

    Sent from my BlackBerry 9650 using Tapatalk
    07-21-11 11:39 AM
  12. pcgizmo#IM's Avatar
    I had some issues with .600, not necessarily battery drain, but other things so I didn't have it on long enough to really check battery life

    Sent from my BlackBerry 9650 using Tapatalk
    What did you roll back to? I may load 587 and give it a test drive.
    07-21-11 11:43 AM
  13. papped's Avatar
    I haven't tried 587 yet tbh. I'm currently using .524. I kept getting massive lag issues in .600 even after multiple wipes and both on .600 and the .600 hybrid...
    07-21-11 12:42 PM
  14. pcgizmo#IM's Avatar
    I haven't tried 587 yet tbh. I'm currently using .524. I kept getting massive lag issues in .600 even after multiple wipes and both on .600 and the .600 hybrid...
    Ah, wasn't thrilled with 524, had lots of lag when using BBM
    07-21-11 12:53 PM
  15. papped's Avatar
    Not sure, I've been using the 6.0 bbm and it seems ok, but I haven't been using bbm much so I can't really say. Might be worth just trying 587
    07-21-11 01:02 PM
  16. pcgizmo#IM's Avatar
    Not sure, I've been using the 6.0 bbm and it seems ok, but I haven't been using bbm much so I can't really say. Might be worth just trying 587
    I had the beta BBM 6.0.0.111 and had tons of lag on 524. Whatever is bundled with 600 runs much better.

    Battery life seems better on 600 than 524.
    07-21-11 01:07 PM
  17. JLD2k3's Avatar
    I'm having the battery drain issue as well. I installed .600 a while ago and I thought the battery life was much better than .524 until today when the battery went from >90% to <10% in 90 minutes of non-use and a total of 6 hours off the charger, mostly non-use time. 1 phone call of 2 minutes and a couple twitter checks is all I used the phone for.
    07-21-11 02:11 PM
  18. pcgizmo#IM's Avatar
    I'm having the battery drain issue as well. I installed .600 a while ago and I thought the battery life was much better than .524 until today when the battery went from >90% to <10% in 90 minutes of non-use and a total of 6 hours off the charger, mostly non-use time. 1 phone call of 2 minutes and a couple twitter checks is all I used the phone for.
    I have BBM, GTalk and text messages going all day and have 30% battery left after 15 hours of use. How old is your battery?
    07-21-11 02:38 PM
  19. JLD2k3's Avatar
    I have BBM, GTalk and text messages going all day and have 30% battery left after 15 hours of use. How old is your battery?
    I got the phone in September 2010.
    07-21-11 02:47 PM
  20. pcgizmo#IM's Avatar
    I got the phone in September 2010.
    You could try taking it in and getting the battery replaced. It's still under the 1 year warranty.

    edit: How is your signal strength? The radio file changed from 524 to 600, you may be struggling for a signal and that's what is chewing up your battery.
    Last edited by pcgizmo; 07-21-11 at 03:11 PM.
    07-21-11 02:52 PM
  21. JLD2k3's Avatar
    Signal strength has been better than .524. I've been in all the same places today and no issues (nearly 100% battery remains with phone off the charger for 5 hours now).

    Could this be a software fluke that the OS thinks the battery is dead when it really isn't?
    07-22-11 11:10 AM
  22. pcgizmo#IM's Avatar
    Could this be a software fluke that the OS thinks the battery is dead when it really isn't?
    While I can't say that's impossible, I've never heard of that sort of thing happening before. You could try installing Meterberry, or possibly batteryex, to monitor your discharge rate. See if that provides any clues.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-22-11 11:48 AM
  23. browniezz's Avatar
    i really don't want to have to downgrade because i really like .600 but my battery wont even get me through the day anymore, any way i can stop my battery from draining so quickly, thanks in advance
    I feel the same too with you please give me enlightment :P

    Posted from my CrackBerry at wapforums.crackberry.com
    07-22-11 11:59 PM
  24. pcgizmo#IM's Avatar
    I feel the same too with you please give me enlightment :P

    Posted from my CrackBerry at wapforums.crackberry.com
    466 is crappy, change to something different.
    07-23-11 04:57 AM
LINK TO POST COPIED TO CLIPBOARD