1. cm7l's Avatar
    Recently i've had a problem where all the keys on my blackberry stop working all together or the space bar works but when i press it only the letters 'n' and 'm' show up repeatedly.. the touchscreen will continue to work though. i've been able to fix this temporarily by doing a battery pull and i've updated to 7.0.0.353 but the problem is still there.

    thanks
    09-08-11 10:39 AM
  2. brandvista's Avatar
    I got the same issue. Battery pull to recover.
    09-08-11 10:58 AM
  3. Bulldawg's Avatar
    Same thing happened to me, but just once. A battery pull fixed it, and it hasn't happened again. Interesting that others are seeing the same problem.
    09-08-11 11:41 AM
  4. funnykindel's Avatar
    Recently i've had a problem where all the keys on my blackberry stop working all together or the space bar works but when i press it only the letters 'n' and 'm' show up repeatedly.. the touchscreen will continue to work though. i've been able to fix this temporarily by doing a battery pull and i've updated to 7.0.0.353 but the problem is still there.

    thanks
    i would have suggested that you go for a replacement but it seems that it is an OS or app problem since a battery pull can solve the problem.

    did you clean install your os .353?
    are you using any strange app?
    i think you, brandvista and bulldawg should list your apps., so that we can determine if its an app that is causing it.
    09-08-11 01:23 PM
  5. obe1stx's Avatar
    i had the same problem. and it would type nm repeatedly by itself.

    i returned it and got a new one.
    09-08-11 08:09 PM
  6. juicytofu's Avatar
    I had the exact opposite problem. screen died, but the keys and trackpad worked. Did a battery pull and fixed it.
    09-08-11 11:23 PM
  7. jedede's Avatar
    pull battery bro. it will fix it
    09-09-11 01:34 AM
  8. blackberry-unlocking710's Avatar
    This is why this device is so great!! even if it's not working 50% you can still use it!!! brilliant! but a battery pull should fix this issue.
    09-09-11 06:53 AM
  9. caitlinhenry's Avatar
    This is really a serious problem guys. The new phone with such defects is very bad.
    fedakd likes this.
    09-09-11 08:55 AM
  10. cm7l's Avatar
    does anyone else that has had this problem use the music app? because for me anyway it seems to only happen when i am using or was using the music app.

    but it happens more frequently and i don't want to take it back if there is a simple fix but for me at least the battery pull doesn't work
    09-09-11 03:09 PM
  11. dierre's Avatar
    mine does the same thing battery pull doesnt work clean installed 353
    09-14-11 01:18 AM
  12. cm7l's Avatar
    mine does the same thing battery pull doesnt work clean installed 353
    try pressign the mute button when it stops working.. on my phone it temporarily fixed it.for some reason the day when i went to take it back it stopped having this problem and hasn't in almost a week so maybe it was just a fluke and hopefully doesn't come back post-warranty
    09-15-11 04:14 PM
  13. 9900Boldfan's Avatar
    This is really a serious problem guys. The new phone with such defects is very bad.
    Probably why the stock to such a beating in after-hours today. I was going to buy one yesterday at MBK here in Bangkok and noticed that the owner of the shop had a Bold 9900 and he had to do a battery pull twice while I was there. He said it did have some crashing issues. Problem is that if one buys a phone from a guy like him one most likely can not return the phone for a new one like one could buying from a high end retailer or telecom company.
    09-15-11 11:36 PM
  14. ThaMunsta's Avatar
    Mine just did it for the first time tonight. Thanks for the advice guys. Battery pull fixed it. Strange that alt shift del didn't reboot the phone.
    09-21-11 09:17 PM
  15. SinFilter's Avatar
    My 9930 did something similar Sunday night/Monday morning. The call pickup/hangup, menu, back and trackpad buttons all quit functioning. On factory installed 254. Battery pull did not fix my issue. Wiped device, reinstalled os, and still exhibited same symptoms. Took to Vzw store on lunch and they overnighted a replacement 9930 to me on Tuesday. On Tuesday, the buttons began to function. However, at this point some other keys did not function. f, g, a at times.
    I activated the replacement 9930, recovered messages and contacts using Protect. From there installed Bridge, Facebook, and Pandora all from appstore. Phone was functioning fine when I went to sleep. This morning when I woke up, none of the physical keys/buttons did not work. Battery pull did not solve this issue. Took both phones to work, without the battery in either device. When I arrived at work, I placed the battery in the new 9930 and to my surprise it functioned...for a short while. Then I experienced a different set of symptoms. The device seemed sluggish when using the keyboard but the touchscreen was fine. Also certain keys would input yi instead of the intended key input. Battery pulls did nothing to resolve this issue. So I wiped this device, reinstalled the os, and upon entering my bb id, could not due to the yi issue still occurring.
    At this point I am unsure what the issue(s) could be. Absolutely love the device, when it works properly. Wasn't able to get to the vzw store today. Hope I can get a resolution to this soon. Glad to hear that battery pulls have helped others with similar issues.
    09-21-11 11:08 PM
  16. lucascav0729's Avatar
    I was using the music app while running, and all of the sudden a "device is scheduled to turn off at.." sign pop up in the screen. I try to ignore it and keys wouldnt work, I tried to restart it using alt + shift + del ...and it wouldnt work. Unaware that the touch screen was indeed working, I pulled out the battery. Non of the keys were working, but the touch screen was. I pulled it out again, same thing. I didnt know what was going on and didnt pay much attention because I was running. I got home, did a back up, deleted everything using the bb desktop (couldnt do a wipe out cause couldnt write "blackberry") ....then restored it and it seems to be working fine now. Weird, very weird. First problem I've had since I bought it 45 days ago.
    Hope the info helps others with the same problem.
    fryk likes this.
    01-11-12 02:14 PM
  17. ptsantis's Avatar
    I had the same problem with my 3-month old 9930. It is a company phone so it always goes in phone lock mode after a minute or two. One morning it suddenly stopped working, I didn't know that it was a key/button problem, because the phone was on keylock and I assumed it crashed. I removed the battery and turned it on and it worked just fine for a couple of days. Two days later, same thing, only that the battery removal didn't help at all. I could see the phone turning on, then it prompted me for password which I couldn't enter and the phone remained permanently in keylock mode. I could see calls coming in, red light flashing, email sounds but I could do nothing about it. I could only pick up calls from my car's bluetooth system. I returned the phone to Verizon and got a "replacement phone" (refurbished, not happy about it), so far so good. I have to say, even though I was a big BB fan (mainly because of the keyboard), this was strike three for me (strike one being the data outages last year and strike two getting the first 9930 with bad pixels out of the box). If I get one more problem with the phone, my relationship with BB is as good as dead, especially since it is my business phone.
    01-18-12 02:19 PM
  18. BoldTeddy's Avatar
    Hopefully someone will find this helpful. *Fix invalidates warranty*

    This evening I dropped my 9900 on a hard floor. Keyboard and all buttons stopped working, including trackpad, screen lock, volume and hotkey. All buttons lit up as normal on reboot and screen and touch screen worked correctly.

    Trust me you can't get very far without the back key . Phone was unusable.

    I've had a problem with the trackpad before and that turned out to be a loose internal connection, which I fixed myself (invalidating the warranty ). So I had no worries about opening up the phone and checking the trackpad/keyboard connecting plug.

    Put it all back together expecting all to be well... it wasn't. All buttons remained dead.
    Through the panic I managed to think logically. If the screen lock, volume and hotkey weren't working then either I was totally screwed or a different connector, deeper within the phone had come loose.

    Using this video I took the whole phone apart as I had nothing to lose.
    I believe the final connector/plug popped in this video was the problem. This plug is adjacent to the hotkey and I believe it is this plug which connects the all the bezel buttons to the mother board.

    This is just a guess, but it might be that this plug works in series with the trackpad/keyboard plug and both must be 'tight' for full functionality.

    Anyway, anyone who has similar problems and doesn't mind losing their warranty should basically check all internal connections/plugs. Could save a lot of time and money.
    05-25-12 03:42 AM
  19. millze's Avatar
    so did this fix the problem my 9900 is doing the same bezel buttons and keyboard dont work .

    thanks
    05-11-13 09:37 PM
LINK TO POST COPIED TO CLIPBOARD