1. odet27's Avatar
    So My bold 9700 randomly started messing up about two months ago. when you touched the screen or pressed the buttons the screen would sometimes flicker/ become distorted. It eventually got so bad that the screen would just stay white with grey vertical lines.

    I opened the phone open and messed around with the lcd cable and found that if i applied pressure on a certain spot of the cable it would work. Still no good though since as soon as i let go it would mess up.

    I replaced the LCD with one i bought on ebay and all was good and working for a whole day but after work i turned it on and all that would display would be colored vertical lines. Colors would change if i scrolled around or pressed buttons.

    Also my sd card slot was not working which i later discovered a rip in the cable so i ordered a replacement part.

    Here are some pics. if anyone has any idea what the problem could be please let me know! I was thinking that the rip in the sd cable could be the culprit but thinking that the replacement lcd was working just yesterday makes me question what really could be the problem.



    Uploaded with ImageShack.us



    Uploaded with ImageShack.us
    08-10-11 08:47 PM
  2. Zach7's Avatar
    ouch! I am sorry to see that your fix didn't work. Maybe since it worked for a day it has something to do with the connection itself. You may want to look into a local repair shop or send it in to Crackberry for repair.

    Here is the Crackberry contact: https://forums.crackberry.com/e?link...token=vSxO9OSQ
    08-10-11 08:55 PM
  3. Rootbrian's Avatar
    Warranty is out the window now , zach's great advice should work, I recommend the repair shop, then the crackberry contact once it doesn't work out. Choose wisely when finding a repair shop. Price quote first, then make a decision afterwards.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-11-11 12:20 PM
LINK TO POST COPIED TO CLIPBOARD