1. RayRayLiu's Avatar
    Lemme just sum it up for you..

    Blackberry Bold 9000, JSL 6.0 Firmware

    Whenever the battery is inside the Bold nothing loads up, Just a Red blinking LED light, Blinks 3 times then pauses then blinks 3 times again and then pauses.. and so on..

    Can't connect to the PC via USB doesn't even show that there's a connection being made..

    Any ideas what's going on? or how to fix it?

    or is it completely Bricked.

    Many thanks, Ray
    08-12-11 10:58 PM
  2. Zach7's Avatar
    How long has it been since you have used it? It may be a battery that is dead and won't take a charge. Have you left it plugged in overnight to see if it will take a charge at all?
    08-12-11 11:12 PM
  3. RayRayLiu's Avatar
    Uhh basically it was a company phone, then my mate that worked in the company gave it to another mate, and that mate gave it to me..

    It came without a battery and i eventually bought a Unofficial battery for the Bold 9000 (dunno if that was the cause but most likely!!) and after that Unofficial battery the phone just died...

    But tbh.. i've used the Unofficial battery in my Bold 9780 and that's still working perfectly fine.. so i have no clue whats going on with the bold 9000..
    08-14-11 02:36 PM
  4. jono212.'s Avatar
    Uhh basically it was a company phone, then my mate that worked in the company gave it to another mate, and that mate gave it to me..

    It came without a battery and i eventually bought a Unofficial battery for the Bold 9000 (dunno if that was the cause but most likely!!) and after that Unofficial battery the phone just died...

    But tbh.. i've used the Unofficial battery in my Bold 9780 and that's still working perfectly fine.. so i have no clue whats going on with the bold 9000..

    I had a similar issue when I bought an unofficial extended battery for my 9000 it worked fine for a few weeks then did the exact same three red flashes and would not power on.

    I popped the original battery back in and it powered up just fine.

    Sounds like the batteries dead/duff like mine was

    Sent from my BlackBerry 9000 using Tapatalk
    08-14-11 03:12 PM
  5. RayRayLiu's Avatar
    Hmm i've put the original official battery in and it still flashes 3 times pause and repeats.. cant even connect to the computer to reinstall the OS
    08-14-11 06:33 PM
  6. mpmtkd's Avatar
    This should fix it... Ive done it before however all your files will be gone

    http://forums.crackberry.com/tips-ho...ckberry-32322/
    08-15-11 01:36 PM
  7. RayRayLiu's Avatar
    Hmm followed the instructions and apploader can not establish a connection between the computer to the phone via usb
    08-15-11 03:10 PM
  8. mpmtkd's Avatar
    you downloaded the OS and deleted the vendor file?
    08-15-11 03:13 PM
  9. RayRayLiu's Avatar
    Yup, Apploader doesn't even recognise that my Phone is connected.. =/ LO im all out of options..
    08-15-11 03:18 PM
LINK TO POST COPIED TO CLIPBOARD