1. MrFuntzel's Avatar
    Hello forum. Im new here. I got a problem with my BB bold 9700 battery. It says its charging and shows the simbol (the one on the battery), one day it charges, another day it doesnt. And when it charges it charges until about 70, 85 and then it starts going down again. So yesterday i went to sleep with 70% of my charge left. I turned my mobile off and connected it to the charger. When i woke up and turned it on again, it had only 60% charge left. After a few minutes off from the charger it had only 40% left. So what can i do about it? I really need to have my BB charged 100% every morning. Thanks in advance - MrFuntzel

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-10 02:57 AM
  2. latin_teacher85's Avatar
    Get a new battery if it is still under warranty. Might be a short in the battery

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-10 03:00 AM
  3. MrFuntzel's Avatar
    I don think its the battery, cause the same thing happened to my old blackberry. I didnt overcharge it or broke the battery. For any reason it happened to my sister to. But we have diffrent BB models and diffrent chargers.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-10 03:23 AM
  4. latin_teacher85's Avatar
    Might be the OS that you are running. Revert back to the one your carrier has. Or it could be some of the apps you have running on the device. I really don't know other than those two things

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by latin_teacher85; 11-02-10 at 03:57 AM.
    11-02-10 03:44 AM
  5. Rootbrian's Avatar
    Like others said, get a new battery and tell the carrier it will NOT recharge at all, tell them you even tested it in another blackberry. Make sure you do test it in another 9700 and see if it'll get charged fully. If it does get fully charged, then it could be one of three things to rule out:

    1. Your blackberry
    2. The charger itself
    3. The battery

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-10 04:08 AM
  6. klintoncloud's Avatar
    Do you have a different charger? If yes, try using a different charger. Or charge it by connecting it on a computer. Or if you have a spare battery try it as well.
    11-02-10 04:12 AM
  7. rabiashah's Avatar
    hey, also got the same prob. wd my BBB..tried diff>chrgerz n bttry bt of no use.the chrging sambol doesnt appears
    06-25-13 04:26 AM
LINK TO POST COPIED TO CLIPBOARD