1. harrym2088's Avatar
    Hi fellow blackberry users,
    I have recently got this blackberry 9780 handset. It is not switching on. When I charge led comes on but then goes off and then comes back again. It doesn't switch on. I have tried replacing battery but no luck. Can somebody help?

    Thanks in advance

    Posted from my CrackBerry at wapforums.crackberry.com
    07-25-11 05:12 PM
  2. starchit's Avatar
    If pressing the red power key or reinserting the battery doesn't work, take it back to where you bought it.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-25-11 06:48 PM
  3. harrym2088's Avatar
    I have bought this phone second hand. So can't return to the retailer. Just wanna say I've put the thread under wrong forum. It is white Blackberry 9700 not 9780.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-27-11 07:26 AM
  4. BigBadWulf's Avatar
    Harry, I've moved and retitled the thread. If you hit the report button, wemodfia can help you quicker.

    Did it ever work since you've had it, and if so, can yu think of what lead up to it's possible death?
    07-27-11 10:17 PM
  5. Rootbrian's Avatar
    I feel sorry for your loss

    Posted from my CrackBerry at wapforums.crackberry.com
    07-28-11 05:33 AM
  6. harrym2088's Avatar
    Harry, I've moved and retitled the thread. If you hit the report button, wemodfia can help you quicker.

    Did it ever work since you've had it, and if so, can yu think of what lead up to it's possible death?
    I was upgrading to new OS. And it never finished the installation. And now it isn't even recognising the handset. Thanks for changing the thread.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-28-11 05:52 AM
  7. mobibiz's Avatar
    Hi, it for sure is a hardware issue, either the CMOS is causing an error, which can be fixed by replacing the battery or the RAM on the device has gone bad. i'd suggest if nothing works at all, google the CMOS thingi and see if you can do it, but do all these only when before considering chucking out the phone.
    07-28-11 06:10 AM
  8. harrym2088's Avatar
    I did try uploading the software again and it gave me the automatic update for upgrading. It went to 50 % and then in between I got an error saying "Cannot connect to the blackberry device". Am I doin it right? It did work in the first place.
    Any suggestions.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-28-11 02:57 PM
LINK TO POST COPIED TO CLIPBOARD