1. bbsingh9700's Avatar
    I am using BB9700 with OS (6.0 Bundle 2475) (v6.0.0.546, Platform 6.6.0.207).

    Managed to successfully connect to the Wireless router in the hotel while on holiday with fantastic browse speeds and Youtube (following is the diagnostic):
    =========================
    Wi-Fi
    Current Profile: SFL-1
    SSID: SFL-1
    AP MAC Address: 00:18:39:16:10:C6
    Security Type: WEP
    Association: Successful
    Authentication: Successful
    Local IP Address: 198.168.0.58
    Signal Level: -78 dBm
    Connection Data Rate: 48 Mbps
    Status: Network acquired
    Authentication Failure Reason:
    Network Type: 802.11b/g
    Network Channel: 7
    Pairwise Cipher: Not Applicable
    Group Cipher: Not Applicable
    Gateway Address: 198.168.0.3
    DHCP: Successful
    Primary DNS: 198.168.0.3
    Secondary DNS: 0.0.0.0
    DNS suffix: local.lan
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate:
    Software Token:
    Hotspot Code:
    Hotspot Message: Not Applicable
    Hotspot Status: Not Applicable
    ===================
    However, when I connect to my CISCO Valet router at home, I get an error message "Unable to find the requested server". Following is the diagnostic of my home router:
    ===================
    Wi-Fi
    Current Profile: GreenGiraffe
    SSID: GreenGiraffe
    AP MAC Address: 68:7F:74:B3:62:4A
    Security Type: WPA2 Personal
    Association: Successful
    Authentication: Successful
    Local IP Address: 192.168.0.145
    Signal Level: -83 dBm
    Connection Data Rate: 48 Mbps
    Status: Network acquired
    Authentication Failure Reason:
    Network Type: 802.11b/g
    Network Channel: 6
    Pairwise Cipher: CCMP
    Group Cipher: TKIP
    Gateway Address: 192.168.0.1
    DHCP: Successful
    Primary DNS: 192.168.0.1
    Secondary DNS: 192.168.1.1
    DNS suffix:
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate:
    Software Token:
    Hotspot Code:
    Hotspot Message:
    Hotspot Status: Not Applicable
    ==========================

    Would really appreciate help as I now understand that there is nothing wrong with the configuration of my BB.
    08-16-11 07:47 AM
  2. Rootbrian's Avatar
    Try rebooting the router. Either use the options within it's configuration, or hit the reset button on the back of it using either a pin or a pushpin, or unplug it, wait 9 seconds, then plug it back in and wait for it to be ready for use.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-16-11 12:37 PM
  3. bbsingh9700's Avatar
    Many thanks for the response. Tried re-booting the router. But no luck. Same message. I'm wondering, is there something is the "Pairwise Cipher: CCMP
    Group Cipher: TKIP", since this is the only difference between the 2 routers (as mentioned above).
    08-16-11 09:13 PM
  4. wu-wei's Avatar
    Are you prompted to sign in in order to access your router? Since you're running WPA2, you should be prompted to enter a password.

    I see the router is DHCP enabled...are you sure about the DNS addresses? Most times those are dependent on your ISP - first is often the router itself (192.168.1.1) and secondary is specified by ISP.

    I'm sure there's something else I'm missing here, but those are my initial thoughts.
    08-16-11 10:13 PM
  5. bbsingh9700's Avatar
    "Are you prompted to sign in in order to access your router? Since you're running WPA2, you should be prompted to enter a password." - The answer is Yes. I have successfully connected to the router (WiFi icon is white). Surprisingly, I receive my corporate mails even when BIS is turned off. However, I cannot browse, nor check Youtube, which I was able to do by attaching to a different WiFi Router in a hotel.

    Not sure about the IP address though.
    08-17-11 03:43 AM
  6. mithrazor's Avatar
    Have you tried connecting to your wifi through a different device?

    It'll let you know what's the problem, the router, or your phone.

    A quick battery pull wouldn't hurt.
    08-17-11 08:05 AM
  7. Rootbrian's Avatar
    Maybe disabling security on the router and whoever else connects to it, copy and paste their mac address into the mac filter so they cannot connect again. That's what I do, successfully blocking 10 computers right now. Any new computers connecting can also be added to the list. I don't have security enabled due to connection issues.

    Is your router a belkin mimo by any chance, or older apple airport?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-17-11 11:12 AM
  8. bbsingh9700's Avatar
    "Mithrazor" - I connect to the router using my laptop without any issues. I must confess that my SNS is very low (21 - 23 for downstream). However, that doesn't pose any appreciable problem in browsing / downloading. I have already done a battery pull. As I mentioned earlier, I have successfully connected this phone to another router (see diagnostic of SFL-1 above) with very good browsing and Youtube experience. Hence, I don't think it's a problem with the phone.

    "Rootbrain"- My router is a CISCO Valet - which is essentially a Linksys variant probably E10000 (I read someplace). The advantage is that, it provides an easy-to-use Admin Interface apart from having a 20-30% higher range. I do have a guest login feature enabled, which appears in any hotspot search (I live in an apartment block), but I have changed the password from default.
    The Router is WPA2 enabled. Hence, without a password, no one can connect and I use it to connect all devices at home, which is never larger that 3 devices max.

    Does this info help? For those of you who understand these things, I request you to look at the WiFi diagnostic above. GreenGiraffe is the name of my home router and SFL-1 is the name of the router I had managed to successfully connect and browse. Many thanks for the responses though.
    08-18-11 02:05 AM
  9. bbsingh9700's Avatar
    More info after a bit of pottering around, if it's of any help....
    The router is configured as follows:

    Network Authentication : WPA/WPA2 Personal

    Should I try to change network authentication to WEP?
    08-18-11 05:00 AM
  10. breakmedown's Avatar
    I noticed the "Network Channel" to be different on your two network connections. Mine's connecting at 6, same as the one for your home network.

    Also, like someone mentioned earlier, my "Primary DNS" is the same as my default gateway.

    I'd say it has less to do with any of the hardware involved and more to do with their inability to talk to each other. Have you tried turning off your carrier network to see if that'll force it to use WiFi?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-19-11 12:47 AM
  11. bbsingh9700's Avatar
    "I see the router is DHCP enabled...are you sure about the DNS addresses? Most times those are dependent on your ISP - first is often the router itself (192.168.1.1) and secondary is specified by ISP.

    I'm sure there's something else I'm missing here, but those are my initial thoughts."

    Ok. Success at last.

    Firstly let me set at rest the doubters about whether BB supports only WEP. The answer is it supports WEP, WPA, WPA2 without any problem. One should always try manual connection and enter the correct key. Please be careful about entering the exact values of the key whether generated by the router (in case of WEP) or created by yourself (for WPA/WPA2).
    I never had any problem connecting to WiFi right from the beginning, which it always succeeded in doing (whether WEP or WPA or WPA2). But the problem was post connection, it would not browse.
    A stupid issue. I did not enter the primary and secondary DNS address in the router, instead used these as static addresses in the desktop which I normally use to browse; hence I was able to browse from my desktop. For my laptop, I could never browse once connected, but once connected to my corporate VPN (which would provide me with Primary and Secondary DNS addresses), I would browse comfortably. Hence, it took me a long tome to figure out (as all 'other' devices seem to be working fine but not the BB). WuWei's comment set me thinking and this time I configured my router with the DNS addresses (primary as the DSL modem gateway and secondary from the ISP) and the BB browses away even Youtubes perfectly.
    Oh, one more point, set your router to 802.11b/g not 802.11b/g/n (BB doesn't seem to work with 802.11 n).

    Many thanks to all of you for the help.
    08-19-11 01:47 AM
  12. wu-wei's Avatar
    Very cool man....glad you got it sorted.

    I've tinkered for years with TCP/IP and all the sundry little subtleties therein, so I figured there was something gumming it up at the DNS designation. And your report that you were receiving emails but couldn't browse had me scratching my head for other possible problems...

    Regardless, I'm happy I was able to offer some meager assistance.
    bbsingh9700 likes this.
    08-19-11 06:22 AM
LINK TO POST COPIED TO CLIPBOARD