1. fuzzball_uk's Avatar
    Hi all,

    I'd really appreciate your help with this one. I have a 9900 on BIS with one gmail account set up. I have noticed recently that emails are only stored on there for 30 days. Any emails older than 30 days are not shown. I have the settings at "Keep Messages Forever" but this is not happening. I also have reinstalled the OS but it has not fixed the problem. I am on OS 7.1.0.342 (Bundle 1149). Oh, and I have plenty of memory (145mb). Does anyone know how to solve this problem so that I can keep all emails on my BB?

    Thanks!
    Last edited by fuzzball_uk; 08-27-12 at 07:18 AM.
    08-27-12 07:16 AM
  2. MobileMadness002's Avatar
    Are they still in your GMail account online? If so, what's the issue?
    08-27-12 07:49 AM
  3. fuzzball_uk's Avatar
    Yes, they are. The issue is that it's rather cumbersome to have to log in and get what I want (+ I have two-step verification which makes it even more cumbersome). I would like the functionality of having it all on my BB9900 as opposed to logging in every time. Besides, if the phone says I can have it "Forever", then I don't think its unreasonable to expect them to be on the device forever, no?
    08-27-12 08:07 AM
  4. MobileMadness002's Avatar
    Meh, I use remote search, no need to have the device cluttered. But whatever floats your boat.

    PS, I do agree though, forever should be just that, forever.
    08-27-12 08:18 AM
  5. fuzzball_uk's Avatar
    Yes, I just hope RIM sort it out for BB10. There are so many little things that, if and when they do work, are superb. The whole package just needs to be sorted out. Fingers crossed. Anyway, that's an aside. My original problem remains - any help/solution would be greatly appreciated!
    08-27-12 08:22 AM
  6. MobileMadness002's Avatar
    Incidentally, what options do you see now for message retaining. I see the following.

    I just wonder if it might be resolved in the new leaked OS. I usually have mine set for 15 days and also use Recycle Bin PRO (not an endorsement) to keep the deleted messages still on the device.
    08-27-12 08:27 AM
  7. fuzzball_uk's Avatar
    I see the same as you...it is set to "Forever"
    08-27-12 08:34 AM
  8. cszita's Avatar
    bump! Im having the same issue, with the same phone (truth to be told, this had happened with my previous OS6 phones as well). No matter which setting I have (currently keep for 180 days), mails are deleted at ~ 30 days from my gmail, yahoo and IMAP accounts. They still appear at my webmail inbox..

    Any workarounds? Im only able to do a remote search on my gmail account, no Yahoo!
    03-07-13 09:03 AM
  9. patron42's Avatar
    i had the same problem a few weeks ago. i also set it up to remain forever. it actually worked 1 year without a glitch. but last week it deleted every email which r older than 30 days. i had more than 5000mails stored on my phone (7 inboxes)....

    BUT, if u plug your phone to a pc and open dektop software u can see that the messeges are still existing. they appear as "purged mesages". anyone has an idea how to get them back?
    03-07-13 12:10 PM
LINK TO POST COPIED TO CLIPBOARD