1. wirelessgal's Avatar
    Hey everyone,

    I got my 2nd brand new 9900 replacement from Rogers today. The first one was sent back because when I tried to update to the latest software it will not reboot and gave me this error message "App error 606". When I hit reset it went to another screen and says "uncaught exception net.rim.device.api.i18n.Missing. This happened again on my 2nd device. I was updating from 7.1.0.746 to 7.1.0.1033. I called Rogers tech support and the guy was useless. He told me to call back tomorrow and speak with
    someone in teir 2. Did anyone else have this issue when trying to update from .746 to .1033?

    FYI. I have to have to latest OS because if I have any issues with my 9900 in the future, it must be running on the latest software. Also I tried the update on 2 different computers and it's giving me the same error message so it's not a computer issue.
    Rogers can't get to the root of the problem. So I'm hoping someone on here can help me out.

    Thanks.
    Last edited by wirelessgal; 10-18-13 at 11:50 PM. Reason: added more info.
    10-18-13 11:44 PM
  2. eddy_berry's Avatar
    I'll try and help only because I like your avatar. Go leafs. Anyway. When you connect to BlackBerry Desktop Software there is a tab that says applications (I think). When you go in there, it may show changes to OS that are pending. It may be a good idea to also get rid of (uncheck) any language files that you don't use or any apps you don't use. I remember this fixed an error for me a while back, but for the life of me I can't remember what that error was so I really don't know if it will help. Oh yeah and it may show the update as a downgrade. Don't worry about that. Just do it. It's worth a shot. FYI get a Q10. lol I'm just kidding. Good luck.
    10-19-13 12:04 AM
  3. goodayeh's Avatar
    One of your apps , ( or more ) is causing the error.
    Therefore , when re-installing the OS , make a back-up.

    Then install the OS without apps.
    ( uncheck all apps from your back-up )
    Restart the device , test it.

    If all is working well re-install an app ( or a few ) restart & test.
    Doing this you try to figure out which app is creating the conflict.
    10-19-13 03:40 AM
  4. wirelessgal's Avatar
    Thanks for responding guys. @eddy_berry, yes Go Leafs Go.

    I did the update without any data or 3rd party apps. It's a new 9900 from Rogers so I did the update vanilla. I got the app error 606 on .1033. I downgraded to .746 a few times and it worked twice. Then I went to my applications to delete all the languages and apps I don't use and encountered the app error 606 again. I did what @goodayeh suggested and deleted ALL the apps and my phone still won't boot up. Now I'm getting this error message "uncaught exception java.lang.NullPointerException". I give up. I reloaded the software at least 10 times.....between .746 and .1033. Rogers tech support told me there is an issue with the latest software causing the app error 606 with ANY software. He told me I should talk to a dept that specializes in fixing these issues but that I would have to pay $8/mth for this service. I'm not paying for a service that BlackBerry or Rogers caused. I'm a long time BlackBerry user and it's insulting when I'm told I'm not updating it right.
    I lived through the Bold 9000 nightmare. I know how to update ro reload a software! Rogers needs to get BlackBerry to release a fix right way. I was told they started getting calls about the app error 606 and it's related to the latest software update. But they got those customers to pay $8 to speak with another dept. to fix the problem. I can assure you this problem will persist if they need to reload the OS again. Which is why I refuse to pay $8/mth for this service when it's an issue at their end.

    Thanks for the advice. I will escalate this.
    10-19-13 04:52 PM
  5. zocster's Avatar
    Clean your PC from any os, remove DM as well. Run ccleaner. Reboot. Reinstall DM and 1033, use vendelete and run loader.exe

    Sent from my Z10 using Tapatalk
    10-19-13 04:58 PM
  6. wirelessgal's Avatar
    Clean your PC from any os, remove DM as well. Run ccleaner. Reboot. Reinstall DM and 1033, use vendelete and run loader.exe

    Sent from my Z10 using Tapatalk
    I tried this on my brother's computer which has no apps on it other than IE. I D/L DM from BlackBerry and it gave me the same app error message. I forgot to mention my last attempt when I downgraded to .746 and deleted all the apps, the error message I'm getting now is "app error 603".
    10-19-13 06:59 PM
  7. zocster's Avatar
    Try installing as it is without shrinking?

    Sent from my Z10 using Tapatalk
    10-19-13 09:37 PM

Similar Threads

  1. Android apps not working after 10.2 update!!
    By crownone77 in forum BlackBerry Q10
    Replies: 27
    Last Post: 11-02-13, 09:04 AM
  2. Argentina/Brazil - Offline Maps App
    By JNCB in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 10-21-13, 06:42 PM
  3. Calling APPS
    By harant78 in forum Armchair CEO
    Replies: 5
    Last Post: 10-19-13, 08:00 AM
  4. Oakville Place App
    By aminrajabi in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 10-19-13, 12:16 AM
  5. Best Beta OS for Sideloaded Apps?
    By TimeTrap in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 10-18-13, 09:48 PM
LINK TO POST COPIED TO CLIPBOARD