1. NotJo4Ever's Avatar
    Hi all,

    First I wanted to say thanks to anyone with input on this issue. I've searched the forums and can't seem to find anyone with the same problem as me so hopefully I'm not opening a new thread for a known issue. I'm a longtime reader, first time poster.

    I have a BB 9900 (7.1 bundle 2108 version 7.1.0.746 Platform 5.1.0.546) That will not use WIFI sometimes, even when connected to WIFI with full bars of service. I first noticed this issue when playing with the FB app. I live in an area of bad reception for my carrier (BELL) so I connect to my home WIFI, but Sometimes I can't refresh my news feed and this problem persists until I go into the "Manage Connections" page and uncheck "Mobile network". After doing this, I can refresh my Facebook News Feed and all new posts and pictures etc. will load. I can re-check "Mobile Network" at this time and it will continue working from then on (until perhaps the next day or two later).

    The problem really became more serious when I got a notification last night that I'm at 90% of my data cap for the month, (and I still have 2 weeks left!).

    Looking at my bill I have 3 bad nights (1 night of over 340mb! I don't even know what I could possibly have done to download so much at one time...) and so I decided to test out some of my apps to see which ones aren't working on WIFI.
    I completely turned off my 3G data, and tried the browser (which worked fine), Youtube (also fine as it uses the browser), Facebook (worked great), and that was the only apps that worked over WIFI.

    Blackberry app world, evernote, nobex radio, dell voice, all failed to function with 3G data turned off. In each app that has the setting available I have turned WIFI on.

    Does anyone have any idea why this would be? Suggestions for fixing this issue would be greatly appreciated.

    (Since testing this earlier, I have since tested Blackberry App world again and it worked...)


    I don't get this!?
    02-24-13 05:24 PM
  2. windstar1999's Avatar
    To start off with, I see you are with the Bell Network. You can rule out Facebook and Twitter as your data leak issue. They both have unlimited date thru your Carrier (Bell). Blackberry app world should work under WIFI only. That was actually an update that was made several versions ago. Now, I don't think Nobex Radio has a "WIFI only" option. I would use TuneIn or Slacker Radio instead. They both have options for "WIFI Only" If you have gone through 340 MB in a couple of days you defiantly have an app that has a huge leak. Radio apps are usually the culprit. They use the most bandwidth. One thing I would check when you turn off your Mobile Network, got to Network Connections, and Service Status. This should show that everything is not connected except the WIFI. If nothing works, then i would try a wipe and reinstall the OS and start fresh, because this shouldn't be an issue with WIFI. Hope it helps.
    02-24-13 06:48 PM
  3. NotJo4Ever's Avatar
    I haven't got the time to perform a full wipe at the moment, but I believe that the data leak culprit was Nobex radio... It does indeed have a wifi only option, but it doesn't appear to work due to the WIFI issue my phone has, and I've discovered that it seems to just churn away receiving data even when the music playback option is "stopped".

    In short, I think it's a combination of the data leak and my WIFI issue. I will monitor my data usage after removing Nobex and see how things go... Then I will consider the wipe/reinstall after I confirm my findings.
    02-25-13 12:07 PM
  4. NotJo4Ever's Avatar
    As an update to anyone interested, I discovered the root cause of data leak on this device was not Nobex, but rather the blackberry bridge browser...

    I installed a security camera at home (Foscam knockoff) and had viewed the streaming video output on my playbook while using 3G data (away from WIFI) and had left the browser running on the playbook... The playbook went into standby and continued to churn away using the bridge data connection. 10 megs a min * a few hours later... And there went my entire months data plan. (More than 1 gb)

    I was under the impression that when I put the playbook in standby, the video streaming was stopping but I downloaded "traffic monitor for blackberry" from the app world and confirmed it isn't. Hope that helps someone else out there...
    03-11-13 03:58 PM
  5. traveler20's Avatar
    As an update to anyone interested, I discovered the root cause of data leak on this device was not Nobex, but rather the blackberry bridge browser...

    I installed a security camera at home (Foscam knockoff) and had viewed the streaming video output on my playbook while using 3G data (away from WIFI) and had left the browser running on the playbook... The playbook went into standby and continued to churn away using the bridge data connection. 10 megs a min * a few hours later... And there went my entire months data plan. (More than 1 gb)

    I was under the impression that when I put the playbook in standby, the video streaming was stopping but I downloaded "traffic monitor for blackberry" from the app world and confirmed it isn't. Hope that helps someone else out there...
    I’m experiencing the same thing now with my 9930 with none of these apps loaded or running. However, in the past I experienced the same issue (Internet staying on carrier when Wi-Fi was connected) when running older legacy apps that only worked on carrier internet. One in particular was the old BB Gmail app which forced carrier connections while running in the background. Other poorly behaved apps that will force carrier connections with huge amounts of data are the old BB Google Voice app, and the BB Google Maps app. I won’t run any of those apps any longer.

    But I recently loaded the BB Skype app to experiment, and got a rude reminder that VZW crippled it to never work on Wi-Fi. I haven’t run it since, but had to lock it out of accessing the phone on incoming calls. I just set all permission to “prompt” now to see if it’s trying to “phone home” (no pun intended). One call “home” and it disappears for good.
    10-12-13 05:05 PM

Similar Threads

  1. Can't use apps when connected with wifi
    By Jason_Tonr in forum BlackBerry OS Apps
    Replies: 0
    Last Post: 01-24-13, 06:32 PM
  2. 9700 Using Network Data even when connected to wifi?
    By jetstreamblue in forum General Carrier Discussion
    Replies: 0
    Last Post: 05-27-10, 11:43 AM
  3. YM Messenger for BB use data plan even when connected to Wifi?
    By travpm in forum General BlackBerry News, Discussion & Rumors
    Replies: 4
    Last Post: 01-07-10, 07:57 PM
  4. BB asks for password when connecting to 802.1X Wifi
    By gm85 in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 04-04-09, 09:19 PM
LINK TO POST COPIED TO CLIPBOARD