1. DrivenAgain's Avatar
    Ive had the 9700 on AT&T about when it first came out. About a month ago the screen went totally white with weird vertical lines. After a brief search it seems as if this is somewhat of a common problem. I replaced the screen with the proper replacement and it fired up fine. But then I noticed it wouldn't hold a signal, it would flip flop from SOS to Edge to 3G. SO I did another search here and it seems as this also isnt uncommon. Do I just have a dud? I loved my 9700, but now Im back on my trusty 9000 as I await the 9900. Can someone lend any insight into this issue? Thanks guys!!
    J
    07-15-11 02:24 PM
  2. Fubaz's Avatar
    it seems you might have damaged the antenna on swap.
    not 100% sure though
    07-15-11 03:09 PM
  3. DrivenAgain's Avatar
    it seems you might have damaged the antenna on swap.
    not 100% sure though
    I read that as a "diagnosis" on here, but I know it wasnt touched. The 9700 was fun, guess this one is a brick now and I will have to wait for the 9900.
    07-16-11 06:27 AM
  4. Fubaz's Avatar
    I'm sorry to hear about your luck

    I did a housing change on an old Nokia in high school and ruined the antenna so I know what it feels like.

    I'd sell it 'as is' on eBay to recoup some $$$$

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-11 06:34 AM
  5. DrivenAgain's Avatar
    I'm sorry to hear about your luck

    I did a housing change on an old Nokia in high school and ruined the antenna so I know what it feels like.

    I'd sell it 'as is' on eBay to recoup some $$$$

    Posted from my CrackBerry at wapforums.crackberry.com
    thanks for the tips...I may get a new housing off of ebay which should come with a new antenna. I damn near bought a new one with new screen and now a new housing....oh well no worries. My 9000 is great but painfully slow, and waiting for the 9900 is like watching paint dry....so I think I will get a new housing.
    07-16-11 06:51 AM
  6. DrivenAgain's Avatar
    new housing did the trick, back in business!!
    07-25-11 08:50 AM
  7. Rootbrian's Avatar
    thanks for the tips...I may get a new housing off of ebay which should come with a new antenna. I damn near bought a new one with new screen and now a new housing....oh well no worries. My 9000 is great but painfully slow, and waiting for the 9900 is like watching paint dry....so I think I will get a new housing.
    Maybe BBSAK wiping and reloading the OS on the 9000 will bring it back to it's speedy self again? it worked on my 8130 and current 9700.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-25-11 06:26 PM
LINK TO POST COPIED TO CLIPBOARD