1. lilituc's Avatar
    I recently went back to my 9650 after an eight month break where I used the Style. This time around, I can't get the Bold to use my home wireless network at all.

    Oh, I can connect to it just fine - it gets an IP. My network monitoring software tells me the Bold is connected. But once it's connected, I have no internet on the Bold. It doesn't work, period. No apps, no browser. No other device (including the Style) has had any problem with my home network and the Bold worked with it before. Now to get internet working again on the Bold, I have to disable the wifi connection.

    Maybe unrelated, but I have very poor service in my home. The most I can get is roaming on Verizon if I stand near a window. That said, if it's connected to Verizon and wifi is off, the internet on my Bold works just fine.

    Any ideas?

    I have the latest OS update and an b/g/a/n network using WPA2-PSK (AES).
    08-07-11 01:04 PM
  2. southlander's Avatar
    First thing (if you know the subnet settings), is try static settings for your IP and DNS, and gateway. I just looked at the docs on the RIM site and the 9650 supports tons of authentication methods and AES encryption. WPA2-PSK (AES) is specifically mentioned as supported. So if all that is set and you can associate then there might be an issue with the device. Perhaps someone here that knows can chime in on if there is a way to flush any old cached WiFi related data that is stored in the device. To start fresh.
    Last edited by southlander; 08-07-11 at 01:48 PM.
    08-07-11 01:22 PM
  3. lilituc's Avatar
    Thanks. This is weird, but I tried one last time deleting my saved Wifi networks and reconnecting. Now it's working!

    One difference - I went into Service Status and under BIS it says "Wi-Fi." Previously when I connected to the Wifi it still said "Mobile Network." I'm not sure what changed but that seemed to fix it.
    08-07-11 02:27 PM
  4. Tnis's Avatar
    Glad you got it working. I use my 9650 on my home wifi. That way I can make calls and use data at the same time.



    Posted from my CrackBerry at wapforums.crackberry.com
    08-07-11 03:51 PM
  5. cgwrrkid's Avatar
    Had exactly same problem, deleted all the saved wi-fi sites, and added the home one again, not works on wi-fi without the cell network enabled. Thanks for the advice!
    09-01-11 06:36 PM
LINK TO POST COPIED TO CLIPBOARD