Built for Business - Learn more about BlackBerry KEY2
  1. mika16's Avatar
    Why wont my Bold 9900 update past 7.1.0 Bundle 2435? In order to do pretty mych anything on my BB it asks that i have version 10 OS or later. I’ve been all over the website, support pages, contact us page and found nothing! I even called my service provider who claim i have data but my blackberry states im ‘offline’! Ive done the ‘Register Now’ through the Host Routing Table option and have had no success there either! It wont register anything. Which results in my Blackberry ID not working. I’d just like to use my BBM and my Blackberry like the gool old days! As of now all i can do is make calls and receive automated service provider text messages! 😢
    08-26-18 10:31 AM
  2. Bla1ze's Avatar
    1) It's a seven year old phone and some carriers don't even support the services needed to operate BBOS devices anymore.

    2) I know you said your carrier said you had data, but did they say you had a BlackBerry data plan that would support BlackBerry Internet Services? Do they even support BIS anymore? For BBOS devices a specific data plan is needed. Without that plan, you get no service.
    mika16 likes this.
    08-26-18 02:10 PM
  3. mika16's Avatar
    I tried out some of the features which work through wifi only. App world still wont do anything my next mission is to find out if my carrier still does bb data plans! Thank you for your response!
    08-26-18 04:08 PM
  4. littlebuff's Avatar
    Why wont my Bold 9900 update past 7.1.0 Bundle 2435? In order to do pretty mych anything on my BB it asks that i have version 10 OS or later. I’ve been all over the website, support pages, contact us page and found nothing! I even called my service provider who claim i have data but my blackberry states im ‘offline’! Ive done the ‘Register Now’ through the Host Routing Table option and have had no success there either! It wont register anything. Which results in my Blackberry ID not working. I’d just like to use my BBM and my Blackberry like the gool old days! As of now all i can do is make calls and receive automated service provider text messages!
    Your 9900 has the latest of its OS already. OS 10 is different platform and won't work on your Bold.
    Check for BIS with your carrier as recommended. If the carrier still provides BIS, you may still have to ask for someone there who knows how to send the service book to your phone.
    Otherwise, check out this stickies: https://forums.crackberry.com/blackb...l#post13243683
    08-26-18 08:34 PM
  5. littlebuff's Avatar
    Delete double post
    Last edited by littlebuff; 08-27-18 at 06:34 AM.
    08-26-18 08:34 PM

Similar Threads

  1. Will BlackBerry resolve the camera issues with updates?
    By SAKET AHUJA in forum BlackBerry KEY2
    Replies: 57
    Last Post: 08-27-18, 09:44 PM
  2. The jvm error 517 loader I can not find to fix my dads foon
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 08-26-18, 11:29 AM
  3. Google play games are not working on my phone
    By JASRAJ SINGH WARAICH in forum Ask a Question
    Replies: 1
    Last Post: 08-26-18, 02:55 AM
  4. My Q10 pulled a no powering up shenanigan yesterday
    By Jamaa in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 08-25-18, 07:44 PM
LINK TO POST COPIED TO CLIPBOARD