1. sanchokobe's Avatar
    This was an issue on my 9700 running OS6 which I was never able to resolve, and it looks like it's still an issue on my 9900 running OS7.

    The WPA2 Enterprise Wi-Fi network at work requires the use of the "UTN-Userfirst-Hardware" CA, and this cert is installed on the phone (as it was on the 9700). I can see it when I look at the phone settings, and it also shows up in BB Desktop Manager as being valid and installed on the phone.

    But when I set up the wi-fi connection, and am prompted to choose a certificate authority, the certificate does not show up on the list.

    I've seen someone who way back in May posted the exact same problem here and on a few other sites, but never got a resolution. So I know I'm not the only one with this problem. Anyone else having a problem with a valid CA not being selectable when setting up a wi-fi connection?

    Thanks
    09-08-11 09:51 AM
  2. srotman's Avatar
    I'm in the same boat. I used to work for a major Canadian mobile carrier and when at work we had WiFi that used the same certificate. All my colleagues with Androids and iPhones could connect to the network seamlessly. All the BlackBerry users just sat back and watched with envy.

    Now I'm back in school where the school's WiFi uses the same certificate, and again I'm left watching others with Androids and iPhones enjoying seamless WiFi while I rely solely on cell reception.

    It's weird because my Torch 9800, and now Bold 9900, both have this certificate in it. You can see this if you go into the 'security' section of the phone and list the included certificates. But for some reason RIM forgot that people use this for WiFi and so we can't use it for that.

    I'm at a loss for how to deal with this and I'm not to optimistic about it being fixed if I send a bug report to RIM, but I'll give it a shot.
    09-22-11 09:15 PM
  3. torchfiend11's Avatar
    I have the same problem with my Blackberry Torch 9800. I am attempting to join my University's secure wireless network which requires the UTN-User First Hardware CA certificate. I went into my device settings and saw the certificate in the list but when I went to set up a wifi network with WPA2 Enterprise security, I did not see it in the list of certificates. Can anyone advise on this issue? Is RIM aware of this?
    10-03-11 07:50 PM
  4. mssca's Avatar
    I am also a University student and I don't use wifi often since I NEVER go over my data limits. But considering there are many many new Bold 9900s in our school (a lot of people have 9900s in my school), this must be a huge pain for many people.

    I would also like to know if there is a solution for this... I gave up on this looooong time ago.
    10-03-11 08:56 PM
  5. torchfiend11's Avatar
    Guys, I finally figured it out. I was googling this issue this morning to see if anyone had found a possible solution. Check it out:

    WPA2-Enterprise - BlackBerry Support Community Forums

    To sum it up, all you need to do is go into your wireless network settings and switch your Enterprise Sub-Type from PEAP to LEAP and there is no CA certificate validation required! Worked like a charm for me . Now connected to my University's secure wireless network and enjoying the blazing fast speeds! Hope this helps!
    10-09-11 11:54 AM
LINK TO POST COPIED TO CLIPBOARD