1. faddahype's Avatar
    Hello I need some help

    I have an unlocked verizon 9930 for tmobile and i have the blackberry feature on my account and the host routing table is blank..I tried to register it from the option menu on the phone but it did not work. My BBM is not working

    Do you have any idea on how to fix this???
    10-18-11 06:59 PM
  2. besartk419's Avatar
    Call tmobile. Ask them to try and push the books out to you. Tell them you're using an unlocked 9930 and they'll try and work with you

    Posted from my CrackBerry at wapforums.crackberry.com
    10-18-11 08:37 PM
  3. faddahype's Avatar
    i tried but they had no idea what to do...at one point the rep jus hung up the phone
    10-18-11 08:54 PM
  4. claykin's Avatar
    9930 on T-Mobile? Unless you live outside the US (and territories) it won't work.

    Are you seeing "T-Mobile" above the clock?

    Maybe try to connect to a Wifi network and try again to register device.

    Have you tried to send Service Books? Are you sure T-Mobile has proper IMEI for this phone?
    10-18-11 09:00 PM
  5. faddahype's Avatar
    Yes Tmobile is above the clock along with "edge" and not "EDGE"...i manually uploaded the service books so i can get the web with "edge"...but i can not register the host routing tables..so application, emails, BBm does not work
    10-18-11 09:47 PM
  6. besartk419's Avatar
    Hmm...did you try wiping the phone and putting on a Tmobile OS? Maybe that might do the trick? A complete wipe the OS,installing the Tmobile OS.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-18-11 10:24 PM
  7. claykin's Avatar
    T-mo OS will not work on 9930.

    Lower case edge indicates no full data connectivity. Maybe try loading new 9930 OS to see if this improves GSM capabilities.
    10-18-11 10:33 PM
  8. besartk419's Avatar
    Yeh. Maybe you're best bet is just trying fresh. Reloading the OS and trying the steps over. Verizon just released their new official OS anyway,maybe try updating the OS. And idk what reps you had on Tmobile but they sounded messed up. Sometimes I ended up with people from their blackberry departments who just read off the screen. You have to try and get someone experienced with blackberrys working at tmobile to try and understand why it might not be registering to their network. It should work because any phone that's unlocked should be able to register.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-18-11 10:50 PM
  9. ssupreet's Avatar
    I have a similar issue, its driving me insane ..
    I was using an unlocked verizon branded 9930 in india with Vodafone, it was working perfectly..
    Now i moved to Dubai last week and have been tryin to get it to work with DU network but can't get it registered and again host routing table section is empty, called there blackberry helpline, they say that its not registering because the device is associated to some other network where as per the vodafone guys its already released.
    donno wat to do .

    Did anyone face similar issue and how was it resolved..
    10-19-11 04:10 AM
  10. Acelx's Avatar
    This is why i tell people never buy a unlocked CDMA phone to be used on a GSM network.. it never will work 100%..

    did you try this? HowTo:Get All Features (Browser, MMS) Working on T-Mobile w/Unlocked Storm 95xx

    when i had a storm on t-mobile i couldn't get it to work 100% to i try this..

    follow the link above and just think of it as the bold 9930 being the storm, maybe your phone isn't unlocked?
    Last edited by YoungAceAtlanta; 10-19-11 at 04:18 AM.
    10-19-11 04:16 AM
  11. aackberry's Avatar
    Happened to me 2 weeks ago. Imported from US and unlocked Verizon 9930...was able to get EDGE on one GSM carrier but was "edge" on another GSM carrier (AIS GSM). I saw this as a problem because I travel between China (CHINA MOBILE), Thailand (AIS GSM), and US (AT&T) and use BB service with a separate sim card in each country I visit. Who knows what could've happened?!

    I returned it for an authorized dealer's 9900, and have had no issues with ANY carrier so far. No more CDMA, even if you can tinker around with it and some people do use it successfully, it's just A BIG HEADACHE when you don't know who to fix the problems ahead.
    10-19-11 06:20 AM
  12. faddahype's Avatar
    Yeh. Maybe you're best bet is just trying fresh. Reloading the OS and trying the steps over. Verizon just released their new official OS anyway,maybe try updating the OS. And idk what reps you had on Tmobile but they sounded messed up. Sometimes I ended up with people from their blackberry departments who just read off the screen. You have to try and get someone experienced with blackberrys working at tmobile to try and understand why it might not be registering to their network. It should work because any phone that's unlocked should be able to register.

    Posted from my CrackBerry at wapforums.crackberry.com
    How do I reload the OS?...where do i find the OS file?
    10-19-11 12:20 PM
  13. freethisberrydotcom's Avatar
    10-19-11 12:54 PM
  14. coralice's Avatar
    the tmobile 9900 says it uses band 850 which is the same as att... will the 3g work on it?
    10-21-11 06:45 PM
  15. cold war kid's Avatar
    the tmobile 9900 says it uses band 850 which is the same as att... will the 3g work on it?
    T-Mobile USA uses bands 1700/2100 for 3G, not 850. So no, a T-mobile branded 9900 will not get 3G on AT&T.
    10-21-11 07:38 PM
LINK TO POST COPIED TO CLIPBOARD