1. Aceroller's Avatar
    I am picking up a 9900 on ebay today and have my choice of a Rogers or an unbranded one (Bell, Telus, etc) both are the exact same bands so I am assuming it makes no difference which one I choose. Does anyone have an unbranaded canadian 9900 and getting H+ on AT&T? Thanks for the feedback.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-21-11 10:01 AM
  2. austriker's Avatar
    im not sure, check the band frequencies. I do know that I am running a 9900 rogers unlocked on att and getting H+ speeds though. It is very quick.
    09-21-11 12:22 PM
  3. big samm's Avatar
    I am picking up a 9900 on ebay today and have my choice of a Rogers or an unbranded one (Bell, Telus, etc) both are the exact same bands so I am assuming it makes no difference which one I choose. Does anyone have an unbranaded canadian 9900 and getting H+ on AT&T? Thanks for the feedback.

    Posted from my CrackBerry at wapforums.crackberry.com


    I have a unbranded one from bell unlocked it and I'm using it on Rogers... Ans yes I got the H+ sign near the signal bars... If you get a Rogers one or a bell you should get the H+ on att if you have 3G where you live... I remember techno buffalo did a review with a Rogers unit and they had the H+ sign on att network


    Sent from my Bold 9900 using Tapatalk
    09-21-11 12:32 PM
  4. alunkkk's Avatar
    Please use search before creating new thread..
    there are 2 thread, you can find the answer why unbranded 9900 not showing H+ icon.

    H+ issue on 9900 unbranded.

    anybody from the UK who is on Vodafone has got H+ yet?
    Last edited by alunkkk; 09-21-11 at 12:40 PM.
    09-21-11 12:37 PM
  5. Aceroller's Avatar
    OK.......I ordered one that will either be Telus or Bell. Does anyone have a Telus or Bell on AT&T, and are they getting H+? Thanks.
    09-22-11 12:24 PM
LINK TO POST COPIED TO CLIPBOARD