1. austriker's Avatar
    hello,

    I am having issues with bb maps to install. I cannot do it over the website because it says my device does not meet specifications (its a 9900, how can it not?!).

    So I tried to install via DM on my macbook via the applications part of DM and it gave me this message:

    Blackberry Desktop Software failed to validate your Blackberry device update.

    Aborting install due to validation failure. Some packages contained unsatisfied dependencies.



    I remember having it on my 9900 but for some reason when I did a wipe and restore a few months ago it disappeared. I don't remember exactly if thats what caused it but I think so

    Any suggestion o great crackberry oracles?

    Thanks. Hmm I am using gmaps right now but would love to get some BB mappage in..
    12-22-11 11:29 AM
  2. austriker's Avatar
    am the only lowly one stuck with gmaps?
    12-31-11 02:39 PM
  3. SwitchBeach's Avatar
    You need to load it from the Application Loader (or the BlackBerry Desktop Software). (As noted, you can't load it OTA on that device.)

    If it's not working on your computer, try a different computer. Preferably one running Windows to eliminate your issue.

    Having said that, in my opinion, Google Maps is far superior to BlackBerry Maps.
    12-31-11 03:06 PM
LINK TO POST COPIED TO CLIPBOARD