1. Bjoe9's Avatar
    I have a unlocked 9900 with telus, when I try to use a non telus sim, like rogers, it takes me to the blackberry login screen. I enter my user email and password, it always fails. I know I'm using the correct password but it always fails. Is there something I'm doing wrong? Is there a way to bypass this?
    09-08-11 10:34 PM
  2. freethisberrydotcom's Avatar
    Which login screen are your referring to? The blackberry id or blackberry email setup?
    09-09-11 08:45 AM
  3. Bjoe9's Avatar
    the blackberry id
    09-09-11 01:38 PM
  4. freethisberrydotcom's Avatar
    Are you able to web browse on your device?

    Worst case go to blackberry.com/blackberryid and reset your pw..
    09-09-11 02:11 PM
  5. Bjoe9's Avatar
    password doesn't seem to be a issue because when i put my original sim back in, i can use the same pw ok.

    as for using the wifi, i have no option to turn it on as the login comes on as soon as the phone starts up
    09-10-11 01:29 AM
  6. Canuck13's Avatar
    I am having the same problem. The blackberry ID i started with the phone wont work, i have almost "incorrectly" used up my 10 tries. I know my password and ID is correct.

    Please Help CB
    09-10-11 07:08 AM
  7. Bjoe9's Avatar
    I am having the same problem. The blackberry ID i started with the phone wont work, i have almost "incorrectly" used up my 10 tries. I know my password and ID is correct.

    Please Help CB
    i use a telus 9900 from vancouver, not sure if this is a coincident.
    09-11-11 11:35 PM
  8. freethisberrydotcom's Avatar
    try creating a new blackberry id
    09-12-11 11:04 AM
  9. blackberry-unlocking710's Avatar
    Try to contact your carrier and ask for some support with that issue...
    09-12-11 12:40 PM
  10. Bjoe9's Avatar
    Try to contact your carrier and ask for some support with that issue...
    not sure if what will work since i was trying to use some one else's sim
    09-13-11 01:27 AM
  11. niks1's Avatar
    I had this happen to me. Basically, when you change a SIM card, you have to register through BB ID. However, if you have any data, contacts, etc. on your phone, the whole process gets hung up. The only solution I found was to wipe the device clean, put in the SIM and then reload all data. It is a pain, believe me I know, but so far the only way I found. Hope it helps.
    This must be a OS glitch since my 9360 works OK when swapping SIMs.
    09-13-11 03:53 AM
  12. jlogan911's Avatar
    My OH just got a 9900 and is having a similar issue with regards logging into her blackberry ID. When I switched her device from her old 8520 to the new 9900 I switched the devices and then switched the sim. Sounds like I should have switched the sim and then the device data? Will have to try again tomorrow night. She can BBM but not email, and was able to log in to BB app world to download the new BB app world but then hasn't been able to log into the ID on the device, only on her laptop.
    09-13-11 07:22 AM
LINK TO POST COPIED TO CLIPBOARD