1. Pilchard's Avatar
    The trackpad on my wife's 9900 has stopped working. It still clicks but doesn't move the cursor around on the screen. I have tried "ALT Right Shift DEL" but it still doesn't work.

    Any suggestions? It's an O2 UK one bought at the end of October 2011 so I presume it's out of warranty.
    02-09-12 10:32 AM
  2. Fnord's Avatar
    Warranty is generally 1 year. Try giving your carrier a call.
    Pilchard likes this.
    02-09-12 11:18 AM
  3. Pilchard's Avatar
    Thanks, it is a 12 month warranty so I will take it to the local O2 shop. Sadly we lose the 9900 for 3-4 days.

    I wonder if this is a common fault - I haven't noticed any threads about it. There have been threads about poor RIM production quality, and this is another example.
    02-09-12 01:26 PM
  4. kccman's Avatar
    I assume you've tried a battery pull?
    02-09-12 01:31 PM
  5. Pilchard's Avatar
    I assume you've tried a battery pull?
    Yes, and sadly no joy
    02-09-12 03:35 PM
  6. byul's Avatar
    well you can play a little more and see if it goes away by time.
    if not the best thing you can do is to return it for repair.
    you can ofcourse try fix it yourself, but that would be prio #2.
    3/4 days is pretty fast thought, my cousin needed to wait 2+weeks,
    to get his enter button fixed, which turned into a touch button instead of click lol.
    02-09-12 03:39 PM
  7. MrsD.'s Avatar
    I started having problems with my trackpad after a battery pull. (Sometimes my 9900 doesn't like to charge). Once I put my caseMate back on, my trackpad wouldn't scroll. I took off my case to do another battery pull, scrolling started to work. Put the case back on - no scrolling. Take the case off - scrolling works again. I guess my berry just wants to be naked.
    02-15-12 08:01 AM
LINK TO POST COPIED TO CLIPBOARD